HDD disks stuck in read-only mode in a non-dual installation

Hi all :hugs:, I have posted here all the necessary information regarding the problem I need a solution for. I have internal HDDs in "Other Locations". When I access any of them, the drive mounts and I can interact with the files, but I can't delete anything or create a new folder, etc. The drives seem to act as if they are in "read only" mode. Also, when I try to add one of those HDD disks to the Steam store manager, I get the error message "New Steam library folder must be on a filesystem mounted with execute permissions".

Although I know some concepts, I am new to Linux and need help to solve this problem without damaging the contents of my HDD disks. I appreciate help on this in advance.

Platform: Desktop
BIOS-Motherboard: ASUS ROG MAXIMUS VIII HERO
Fast Startup: Disabled
Secure Boot: Disabled
CSM: Enabled
TPM 2.0: Enabled
Intel Virtualization: Enabled
Graphics Card: NVIDIA GTX 1070

System installed: Zorin OS 16.1 Core
Install media: USB flash drive - 64GB
Installation utility: balenaEtcher v1.7.9
Installation via NVIDIA option: Yes
LVM installation option: Disabled
Software updated after installation: Yes
Internet enabled: Yes

Target storage drive: SSD (completely empty - full erase - no dual boot)
Additional hard drives: Basic and Dynamic HDD Disks

480 GB Disk (2 partitions):

  • Volume 1 - Size 480 TB

  • Partition type - Linux Filesystem

  • Format - Ext4 (1.0) mounted on [root]

  • Volume 2 - Size 537 MB

  • Partition Type - EFI System

  • Format - FAT (32-bit-version) mounted on [/boot/efi]

6 TB Hard Disk (3 partitions):
Format - NTFS

  • Volume 1 - Size 6.0 TB

  • Partition Type - Microsoft LDM data

  • Volume 2 - Size 16 MB

  • Partition Type - Microsoft Reserved

  • Volume 3 - Size 1,0 MB

  • Partition Type - Microsoft LDM data

4TB Hard Disk (3 partitions):
Format - NTFS

  • Volume 1 - Size 4.0TB

  • Partition Type - Microsoft LDM data

  • Volume 2 - Size 122 MB

  • Partition Type - Microsoft Reserved

  • Volume 3 - Size 1,0 MB

  • Partition Type - Microsoft LDM data

4 TB Hard Disk (3 partitions):
Format - NTFS

  • Volume 1 - Size 4.0TB

  • Partition Type - Microsoft LDM data

  • Volume 2 - Size 16 MB

  • Partition Type - Microsoft Reserved

  • Volume 3 - Size 1,0 MB

  • Partition Type - Microsoft LDM data

2 TB Hard Disk (3 partitions):
Format - NTFS

  • Volume 1 - Size 2.0 TB

  • Partition Type - NTFS/exFAT/HPFS

  • Volume 2 - Size 1.1 MB

  • Unallocated space

Can you please check if the package ntfs-3g is installed?

sudo apt install ntfs-3g

You may need to check your drive permissions -

Chmod won't work if you are loading them from the fstab (mount on boot). You will actually need to edit the permissions in /etc/fstab (also where to check if the ntfs-3g notation is included in the configuration line).