HDMI-Port not working

Hey there,
I'm fairly new to Zorin and linux as a whole and I just can't seem to figure out how to connect my system to a TV/Monitor via hdmi. I'm using a Lenovo Ideapad 330s with the GTX1050... Zorin just doesn't seem to recognise the second display. It acts like I didn't plug in an hdmi cable. It has to be a Software issue since it is working fine using Windows. I'm very thankful for any responses.

What is your graphics card? Are you using Nvidia?

sudo lswh -c video

Are you logging in on Wayland?

1 Like

Welcome to Zorin OS XtremeHuhn! :slightly_smiling_face:

OK, I am going to have you click on the Zorin :zorin: icon bottom of screen, then please click settings. Scroll to Display, click on it.

Now in your display menu, if you have a second display connected, you should see it here. The 2nd display might be turned off, so you will have to turn it on via a toggle.

Also, you say you have a Nvidia GTx1050 GPU, that is your discreet GPU, do you have your Nvidia drivers installed?

If you have selected your Nvidia driver, then you should also have the Nvidia X Server Settings APP on your system. Click the Zorin icon again, type Nvidia, click on Nvidia X Server Settings. You should see this on this tab, you can also manage your displays here as well.

I hope this helps...


1 Like

Ah... see, I missed that.:stuck_out_tongue:

2 Likes

Yes you did, but I chose not to rub it in, you've been through enough today, as I have since learned after waking up. So sorry Aravisian. Hugs :hugs:

thanks for your in depth answer!
sadly the second screen doesn't show up...

I think it might be an issue with the nvidia driver since when I open Nvidia X Server Settings only this shows up: nvidia x server settings

1 Like

You are very welcome, I try to be as helpful as I can. It doesn't always work, but at least I try.

I think I already know what the problem is. In Additional Drivers, does the Nvidia driver you selected have the word TESTED in the name? IF so, bad, very very bad, all the bad. Get rid of.

Instead, choose the next highest Nvidia driver that is in your Additional Drivers list, that has only the word PROPRIETARY in its name, very very important you switch to that driver.

Reboot the computer once the driver is fully installed.


I have now tried 4 different drivers, none of them worked :confused: this is where I'm at right now:

the NVIDIA X Server Settings screen still looks the same as in my last post... it really is quite tricky to get nvidia cards to works properly on linux, hmm? :smiley:

Well, it can be. But usually in my experience, as long as the proper driver is used, Nvidia GPU's are easier to setup in Linux, then AMD GPU's. This is because Nvidia has greater driver support, and easy of integration in Additional Drivers, as you are clearly seeing.

AMD users have to hunt down their drivers from the internet, and install them manually, and hope their system doesn't BLACK SCREEN upon reboot.

OK, my next thought is, did you disable SECURE BOOT in the BIOS? Because if SECURE BOOT is enabled, as it is usually by default on Windows systems, then that could be interfering with Linux ability to interface with the hardware.

This is why we all preach to disable SECURE BOOT with Linux. Also, if your system is new enough to have TPM, we recommend disabling that in the BIOS as well. But for now, lets just focus on SECURE BOOT.

Do you know how to get into your system BIOS? Shutoff your computer, then press the power button to turn the computer on.

The button you press to enter the BIOS depends on the brand of the machine. Its either spam hit the DELETE key like your life depended on it, or SPAM the F2 key like your life depended on it, or spam the F12 key like your life depended on it.

I don't know which yours uses without looking it up, and I am eating my dinner right now, so yeah. Anyways, hope this helps

Have you checked if you are Logged In to Zorin on Wayland?
Logging into Wayland commonly causes this issue.

1 Like

that was it. I disabled secure boot via the BIOS and it worked immediately. thank you so much!

2 Likes

You are super de duper welcome there XtremeHuhn! Glad we were able to help you solve this issue, so you are able to get back to using your computer like and feeling happy! :grin:

Also I want to note, even though I had the solution, this is a team effort. So I'd like to take a moment to thank Aravisian, for taking a moment out of his time, to help with this as well.

And todays wise Linux lesson is? For a smooth working computer, disable SECURE BOOT you will.