Headset issues in linux/Zorin

I have a small "problem" with the 3.5mm jack in linux/Zorin. First of all i uses Zorin on a old full spec iMac (Late 2013), 32GiB ram, 256 GB SSD, Nivida MX780m.

Linux and Zorin works just fine, but not for the 3.5mm jack. Speakers works fine, Bluetooth headset works fine.

But when i plug in a headset into the 3.5 mm output, there is no sound. The headset is recognized, the icon changes, you can see that there is sound on the VU meter. But nothing comes out of the headset itself.

No headset works, have tried variants with audio controls on the cable and headsets without this function. Nothing works.

What's the deal here? How to fix this if possible?

1 Like

Is the headset jack dual-purpose i.e. headphone/mic?
In terminal open alsamixer
Hit [F5] to show all channels.
Unmute (hit M key) at any that show "MM" = muted, and increase volume level.
If you see [Auto-Mute], toggle to Disable*.
If you see [Loopback], toggle to Enable*.
'*for those two, have a play with the different Enable/Disable settings and see if anything works.

2 Likes

Gday @Emil As @zabadabadoo has asked, it maybe the type of connection on the headset.
On the pc does it have 2x 3.5mm jacks? 1x for headset & 1x for mic?
Here a photo of some variants of 3.5mm pin's,
The 4 section pins from memory was released on the Lenovo pc's & can also be used on most phones. i'm not sure about imac pc,
If you have the 2x 3.5mm jacks & use a 4 section 3.5mm jack you can cause damage to the pc.
diff 3.5mm headset plugs

Note: you can get adapters to convert 4 section to 3 section.

1 Like

Sorry for my late answer. Yes it is.

No. There is only one 3.5mm jack. Mye BOSE xc25 looks like nr.3&4 jacks on your image. My Koss Porta Pro looks like jack nr.1

Non of theese gives out sound.

And there was no luck with alsamixer suggestion..

The 3rd & 4th picture's are the correct headset jacks for your pc.
As a side question, with the bluetooth is the bluetooth built-in or do you use a usb receiver?
If you have the usb receiver , try removing it from the usb when using 3.5mmm jack :+1:
I see your using Zorin pro, Do you have PulseAudio Volume Control, will appear in sounds & videos or search pc.
,if so open It, goto the Playback Tab & check it's all unmuted there, Then goto the output devices Tab & see if you have the Port output indicates "Plugged-in" ( you may also side up the DB Gain may help) ?
Try these Fing's :smile: & see what we get.. let us know how you go.

Note: Don't Be sorry for replying late, as there is no time limit, only limited time :smile: One doesn't live on the pc.... wellll ... we all have to sleep :smile:

Sorry, if not try installing PulseAudio Volume Control & then follow the above,

This a old full spec iMac (late 2013), i7, 256GB SSD, 32GiB ram, nVidia mx780m gpu.

I use the iMac's built in bluetooth card. Only thing i can say is that the 3.5mm jack works perfect in MacOS. Is it probably a driver issue?

Ok with the headset plugged in first run terminal & update : "sudo apt update", after that restart pc. If no good then try to install pulseaudio via software or
"sudo apt install pavucontrol".

Also in pulse audio check in the configuration tab, that the output in set to Analogue Stereo Duplex.

Do you mean: mac os and Zorin os just works fine ( is this a dual boot set up )?

...etc

Did you try any of that?

Yes. I did. Still no sound.

No it isn't. It's a clean install av Zorin Pro on this old iMac. :smiley:

Have you looked at pulseaudio control?
did it show headset in "Output" ?