Help! Everything went fine with USB live test, but nothing works after installation

Hi !
I just bought Zorin OS Pro, just after tested it a few hours on the live USB and everything was good (display with HiDPI resolution, bluetooth, sound, trackpad, Wifi).
After the installation (with updates download) + reboot, impossible to use my trackpad, the resolution is at the max (so unreadable on my screen because the text is too small), no sound.
Why can't I use the same drivers as the live USB preview ?
I'm on a brand new Dell XPS (i9 + RTX) and I think drivers for my hardware are not present yet, what can I do ?

As an easy test, I would reinstall Zorin OS. Only this time, Uncheck the box for installing updates as you install Zorin OS.
Once installed, boot up and see if things are working.
If so, open a terminal and relay the output here of

uname -r

Open Software & Updates and check what Additional Drivers are available - you can relay that here with a screenshot.

1 Like

Ok thanks I'm trying the reinstallation, I reply in a few moments when done


Another victim of kernel 5.13 perhaps?

1 Like

That is what I am thinking.
It is strange... I mean... I have been doing this for a little while. I've not seen such regressions, before. But who knows. Maybe I just was more clueless, before and only slightly less clueless, now.

Ok, little update. I've done a new install without update neither proprietary drivers options.
Here is a screenshot during the live USB preview, before the installation (everything is ok)

After the install, this time, the system seems to work perfectly (I didn't tried the Wifi/fingerprint/webcam yet).
The proprietary drivers windows says I'm using nvidia driver (470) but I said no during the installation (wtf), and the about windows says I'm using another card.
Here is a screenshot at this point

A lot of updates are available, I'm trying them

Ok, please use the 495 Proprietary, Not the 470 proprietary tested.

Please do as asked above and in terminal, run

uname -r

and post that output here.

Done, set the nvidia-495 (with UEFI password), reboot and then :

The system seems to work fine. But I don't understand the problem, because I ran all the updates and now use the last proprietary driver version. So that means the bug is from the install program ?

@eax Can you do that little thing for @Aravisian please.

1 Like

Do you have Secure Boot enabled?

Oops sorry I forgot. It's 5.13.0-28-generic

Yes (dual boot with Windows 11, but I won't use it)

Please be cautious using Secure Boot. It can interfere with Linux. It is for Windows only, so I can see how you would have it enabled for Windows. generally, it is best to have it disabled if using Linux.

It may have been a corrupted file, rather than a bug.
Or the "tested' Nvidia driver - which is notorious...

Sometimes it does help to install, first and run the updates after the installation, instead of during. I used to recommend that as the only method - though things seem to have improved in the last year or so.

But does this all mean you are fixed up and working?

Yes, everything is fine now, thanks for your help.
I set the thread as "solved".
Have a good day :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.