Help - Extremelly slow Installer

I am trying to install Zorin 16 on my father's computer (currently running Z15). I am able to boot the USB (made with balena), but the it takes forever for the installer to go from one page to the next (like 10+ minutes).

Then when I get to the part it asks if I'd like to install updates, opt out of the census, etc, it "hangs" for 15+ minutes before it shows up the error ubi-partman failed with exit code 141. There is no file in /var/log so I can't look at any extra information about what is going on afaik.

The application doesn't crash, it is always responsive to my clicks, it just takes forever to advance from one screen to the next. I have no clue what is causing it, System Monitor shows there is no load on the CPU/RAM; barely using any resources. System is kinda beefy too: AMD Ryzen 3 3200G and 32 GB RAM.

If I press Try again, after a while I get the same message again...


After retrying it a few times, I decided to click on Continue anyway; that way I was able to advance to the next screen, but now this next screen has been showing up for the past 30 minutes. Is any of this normal?

Again, window is responsive. I can replace the pin anywhere on the map... It just won't advance... Installation hasn't even started. Any clue what could be causing it?

In your BIOS / EFI settings are you set to AHCI or RAID?
You might try AHCI if in RAID.

I left the computer on overnight. Now when I came back to it, it showed the screen to create user. I filled it out and then pressed continue. Then it proceed to say it was installing the OS. But it never prompted me to choose a drive to install it on (there is more than one on this pc). So I cancelled it immediately, and the Installer said the installation was complete (obviously not true). This is so weird.

The boot menu lists the USB drive 2x, one as 'USB Name', and another as 'UEFI: USB Name'. I always choose the one without UEFI on it when booting. Could that play any role?

I will look at this now. I have never messed with that. So whatever is there came like that, and wasn't an issue when installing Z15. Would changing that result in me being unable to access files stored in other HDs in the computer? I don't mind if the main SSD is formatted, but the backup of its files are stored in an HDD in the computer (NTFS) that is used for backups/storage.

It is set to AHCI. MTB has one of those annoying mouse enabled BIOs. I could not see if secure boot was enabled, but Legacy + UEFI is enabled as opposed to just UEFI.

It might.
On a modern machine with Zorin OS 16, you really should opt for UEFI boot as opposed to Legacy.
Legacy can be used should there be a compatibility issue or if Windows is being dual booted and it is Legacy boot.

No, it should not. It deals with how SSD's are recognized.
It has no relevance on formatting the drive.

Was Zorin OS 15 previously installed?
Were any other OS"s installed?
On the Drive, is there an EFI partition for the bootloader (You can check in Zorin OS 16 LiveUSB using gparted application)?

Ok, I've identified the culprit. Apart from the SSD, my father had two HDDs in the machine. One of them was a 2TB hard drive that used to be his old Windows 7 install. He never removed it after migrating to an SSD... It had bootable flags (bc windows was installed in it), 64k bad sectors in it, and wouldn't even mount in Nautilus (it would as of last week). Once I removed it from the system, the installation went smoothly. Thanks for your help with that.

Now though I am having the issue where booting the system to the default option after the installation (named "ubuntu: SSD Name" in the boot menu) shows a grub screen with a prompt. But if instead I choose the option with just the "SSD Name" in boot options, then it boots up fine. How can I fix that?

1 Like

There are two entries?

Please check your partitions.
See if there are more OS's installed than there should be.
If there are not, an install attempt may have written a bootloader that is now defunct.
You can check with

sudo efibootmgr

See if you have "ubuntu: SSD Name" and "SSD Name" listed.
If you do, note the bootid ( example: Boot0002) of "ubuntu: SSD name"
You can remove it with that Last Number on the BootID.
Let's say the bootID is Boot0001...
You can use

sudo efibootmgr -b 1 -B

To Delete that Bootloader.
If it is Boot0002...

sudo efibootmgr -b 2 -B

And so on...

DO NOT accidentally delete the bootloader bootID for "SSD Name"...

Thank you, I will do a backup with timeshift first tomorrow and then investigate.

That command outputs:
EFI variables are not supported on this system


One other thing, unrelated to the above. What would be the best way to automount an HDD on this computer? Is it with fstabs?
It has two partitions, one for backups and another for storage.
For storage, I was thinking to symlink some of the folders in Home to counterpart folders I'd create in the storage partition in the HDD (bc the SSD is only 240 GB).
So Downloads in Home, would be a symlink to a Downloads folder in the HDD, etc.

I was thinking something like this in fstab.

UUID=XXXXX /media/user/storage ext4 defaults 0 0
UUID=XXXXX /media/user/backup ext4 defaults 0 0

Could doing something like that for this usecase create any issues? Or are there better ways to accomplish this?

Hmmm... so you are using MBR (Legacy) Boot?
You have an EFI partition.

Yes, adding the UUID to the FSTAB is the way to go.

Legacy + UEFI is what is enabled in BIOS. I could set it to just UEFI; would that fix it? I don't remember changing that to Legacy + UEFI, so I think it came like that. I remember reading Legacy was recommended for Linux, but I could be wrong.

Awesome

Perhaps it was some years back. But today, EFI with Linux is fine.
IF you are dual booting or were dual booting, it is preferable to stay Like-To-Like
Let's say Windows was installed as Legacy. You would then want to boot Zorin OS as Legacy.
And the other way around.

If Zorin OS is installed as Legacy currently, then you would need to reinstall with EFI Grub to change that. You cannot change the OS Boot in the BIOS Settings.
BIOS Settings only change what the Motherboard Supports.

1 Like

Ok, to do that I would either boot into the flash drive that says UEFI or disable from the BIOS Legacy completely correct?

Yes - or be safe and do both.

Thank you, that did it!

1 Like