Help! How can one upgrade Zorin 15 lite to a PAE kernel?

Hi.

I run Zorin 15 lite on a Pentium D 3.4GHz (32-bit).

Only if I have 3 GB or less memory installed does sysinfo show a plausible memory size. With 4GB or 6GB installed, which is recognized correctly by the BIOS, sysinfo only shows 3271 MB total memory.

The CPU is PAE capable, which is also recognized by /proc/cpuinfo.

I can only assume that a non-PAE kernel is installed, and would like to know by which magic commands I could upgrade this to a PAE-kernel.

The current kernel calls itself "5.4.0-92-generic".

Thank you very much for your attention.

I would be most grateful for help, as I am not well versed in 'apt-get' and the maze of Ubuntu packages.

First, I think we need to examine the question: You may be trying the wrong solution here.
Are you getting an error that led you to conclude you need a PAE kernel?

Dear Aravisian, thank you very much for your reply.

As I already mentioned, sysinfo does not report a correct size of total memory, once more than 3 GB are installed.

I consider this an error, even if linux does not notice that it is one.

And this error is most likely caused by linux mapping the system and graphics card BIOS into the 4GB of memory space it is restricted to without PAE. And consequentially, only 3.271 GB of memory are left for mapping RAM into - whether 4GB or 6GB are installed.

... but if you have a better explanation, please let me know.

We can test it:
You can use Nano to quickly and efficiently act a change in grub.

sudo nano /etc/default/grub

use your arrow keys to move to this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Add the forcepae parameter to change that line to look like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash forcepae -- forcepae"

just like it shows...
tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration and close.
now, in that terminal update grub to enact the changes

sudo update-grub

Reboot and test...

Well ... I did as instructed, and the results are as follows:

'dmesg' shows "PAE forced".

However, the memory reported by sysinfo has reduced by 0.001 GB to 3.270 GB.

And - for good measure - /proc/meminfo shows "MemTotal: 3349188 kB" - which is essentially the same as the result given by 'sysinfo'.

So far it seems to me as if the kernel is accepting the "forcepae" argument on boot but somehow ignores it when it comes to the proof of the pudding.

... but you might have a different interpretation.

Have you performed any MemTests?

1 Like

Hmmm ... running Memtest86 5.01 as installed by the Zorin installation procedure on the HD shows only 3327 MB- a little bit more than Linux, but not the full 4096 MB installed.

Running AND OBSERVING the BIOS RAM test shows 4096 MB, BUT after 33xy MB it just jumps to 4096 instead of displaying all the numbers in between.

The problem is not the RAM itself - that worked well on another system for years.

But it seems that "something" on the Motherboard prevents PAE from happening, despite CPU - and presumably also the Intel chip set - having the relevant capability. Maybe HP just wanted to save a few pennies on the extra address lines on the motherboard.

(There is no BIOS option in sight to "switch on" PAE.)

The BIOS "system information" just adds up the SPD size values from the RAM sticks - and brazenly informs the user about 4096 - or 6144 - MB "installed memory".

Very clever, HP DC7600 BIOS!

And even litigation proof, as every IT lawyer will be happy to explain, that INSTALLED memory is not the same as USABLE memory.

...

Well, as often in such cases, I COULD have found this out myself, had I not been blinded by my rash - and unspoken - assumptions.

So all that is left to me is to THANK YOU VERY MUCH for your well chosen hints which finally guided me to the solution.

...

And meanwhile I even found the fine print in the HP DC7600 manual, stating:

"Above 3-GB, all memory may not be available due to system resource requirements."

How true...

And last but not least I would like to thank everyone concerned for this excellent board, where - thanks to users like "Aravisian" - one REALLY gets help.

Even though I have to bury my pipe dream of an HP DC7600 with a 32-bit CPU and 4, 6 or 8 GB of usable memory.

+++

THIS BOARD IS HIGHLY RECOMMENDED.