Help installing DXVK on Zorin OS

I tried Install dxvk but ./setup_dxvk can not be found.

What method did you use?
You can install DXVK on Zorin OS 16 with:

sudo apt install dxvk

EDIT: When I tested this (See below) it shows that it will install it, but it removes most of the Zorin Packages and Desktop to do so. This is a deadly command that can result in data loss.

Do Not Use.

I tried doing that the
Install dxvk. command was not found

How odd:

sudo apt install dxvk
[sudo] password for mech-1:     
Reading package lists... Done
Building dependency tree       
Reading state information... Done

The following NEW packages will be installed:
  conky-std dxvk dxvk-wine64-development fonts-wine krb5-locales libfaudio0 libstb0
  libvkd3d-shader1 libvkd3d1 libwine-development publicsuffix
0 upgraded, 11 newly installed, 127 to remove and 1 not upgraded


It also said

The following packages will be REMOVED:
  aisleriot alsa-tools-gui autokey-common autokey-gtk awf baobab brasero brasero-cdrkit caja-eiciel
  caja-gtkhash caja-seahorse calf-plugins celluloid chafa cheese cinnamon cinnamon-core code
  conky-all conky-manager2 dconf-editor devhelp dleyna-server evince evolution-ews evolution-rss
  fbreader fprintd gegl gimp gir1.2-ges-1.0 gir1.2-telepathyglib-0.12 gnome-calculator gnome-clocks
  gnome-firmware gnome-font-viewer gnome-logs gnome-mahjongg gnome-mines gnome-power-manager
  gnome-sudoku gnome-sushi google-chrome-stable gparted gpick graphviz grilo-plugins-0.3
  grilo-plugins-0.3-extra gstreamer1.0-adapter-pulseeffects gstreamer1.0-autogain-pulseeffects
  gstreamer1.0-convolver-pulseeffects gstreamer1.0-crystalizer-pulseeffects gstreamer1.0-packagekit
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-base-apps gstreamer1.0-vaapi gtk-3-examples
  inkscape kdeconnect libamtk-5-0 libdevhelp-3-6 libdleyna-connector-dbus-1.0-1 libfprint-2-2
  libges-1.0-0 libglade2-0 libgnomecanvas2-0 libgtk-3-dev libgtkmm-2.4-1v5 libgvc6
  libmagickcore-6.q16-6-extra libpam-fprintd libpango1.0-dev libplayerctl2 libtelepathy-glib0
  libtotem-plparser-videosite libxreaderdocument3 libxreaderview3 libzeitgeist-2.0-0 libzlui-gtk
  nautilus-extension-brasero nautilus-sendto nautilus-share nemo-media-columns nitrogen palemoon
  pango1.0-tools parole pitivi playerctl preload pulseeffects python-nemo python3-gst-1.0
  quadrapassel redshift redshift-gtk shotwell spotify-client sshfs thunar-archive-plugin
  thunar-media-tags-plugin thunderbird transmission-gtk wmctrl xcowsay xed xfburn
  xfce4-cpugraph-plugin xfce4-mailwatch-plugin xfce4-netload-plugin xfce4-places-plugin
  xfce4-systemload-plugin xfce4-taskmanager xfce4-verve-plugin xfce4-weather-plugin
  xfce4-whiskermenu-plugin xfce4-xkb-plugin xournal xplayer xplayer-plugins xreader
  xscreensaver-data y-ppa-manager yad zoom zorin-agent-geoclue2 zorin-os-upgrader

So, on my machine; it will offer to install it but it wants to remove pretty much everything else.
I can only think that there is a cross dependency issue here at play and this one is Very Very Ugly.

Have you looked at:

In the meantime, I would like to investigate what package dvxk in the Ubuntu repositories is.

I also saw some where that the developers took out the ./setup_dxvk file for some stupid reason. That is the exact file I need to install dxvk.

Should I try this? Play Windows games on Linux with Lutris (Tutorial) - ZorinOS, Ubuntu, Linux Mint #linuxgaming - YouTube

I have some really old games I have installed that run flawlessly - Rogue Spear, Rollercoaster Tycoon 1 Deluxe, Ghost Recon 1 (still online servers available), Diablo II LOD, and Warcraft 3. Even connected to Battlenet and updated!

I did give Steam and Halo Infinite a try with Zorin a few years ago when it came out. Ran pretty smooth! Have to enable 'force win gameplay' but, ran. Can't say too much on other games though. As long as you get the correct version of Mono / Gecko, you shouldn't have much, if any, issues. Give it a shot, see what works!

1 Like

Yes and it looks like you need Wine. It also looks like it is supposed to add Vulkan Support - and that is likely to be troublesome in a lot of different ways.

I would advise instead that you use your own suggestion here or use Steam with Proton enabled.
I only use Steam with Proton and do not have WINE installed at all.

I use steam with proton and the games don’t work

I only ever had one game not work - and that was due to it having that Anti_Cheat software that blocks Linux entirely (because the game devs do not care).

You may be focusing on games that have a lot of anti-cheat software, I suppose.

You could just dual boot or use a VM copy of Windows for Gaming purposes.

Dual boot would be the best option if you want to play newer games. A lot of the newer games are not Linux friendly. The anti-cheats usually consider Linux a cheating software (dev bias or because of some libraries), either way it seems that the newer games need a dual boot system, if for nothing else but gaming.

This is actually how I have my system setup.

1 Like

This may be my deal since I hardly pay any attention to newer games at all :stuck_out_tongue_winking_eye:
I do play Valheim, though and that is pretty new.

Did you try this aft sudo apt install dxvk?
sudo apt install -f

I think the solution is to Install a version of dxvk before the latest release. Will try this afternoon and let you know.

I outlined my experience here:

I did not get those messages but I still couldn’t get the latest version of dxvk to work. So I will Install dxvk 1.10.3

Tried downgrading to an earlier dxvk version did not work. :cry:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.