HELP! MY LAPTOP ISNT BOOTING UP ANYMORE (noob @linux)

I have basically messed up bigtime, and I don't know what went wrong.

I wanted to change my driver's from the open source xorg ones to the latest drivers for my gpu: nvidia GeForce 610m.
I looked up on the web to see what version of what drivers I need to install for my gpu and I found it out.
I went to additional drivers application and saw that the driver version for my gpu was already an option for me to switch to and I didn't need to download it seperately from the internet.
I switched to those nvidia drivers and applied the changes.
I then restarted my laptop and was welcomed by a screen displaying the message:
"A problem has occured and the system can't recover. Please contact a system administrator"
Here's an image:

I'd really appreciate any help!
hoping to recover my data and system in one piece...
(p.s I'm extremely new to Linux)
(edit: I think the problem will be solved if I switch to the previous xorg drivers, but I can't boot up the system to apply those changes anymore so I'm stuck.)

1 Like

Don't panic. There is a Good Chance that re-installing Zorin OS is not in your future just yet.

Can you hold or tap the left shift key at boot to access teh Recovery Menu? This menu will have Advanced Options for Zorin.
Open that, then arrow key down to enable networking
Back up to the Recovery Menu...
Then arrow key down to Drop to Prompt
hit enter...
Then type in (Make sure no typoes):

sudo apt update && sudo apt full-upgrade

Then:

sudo apt clean && sudo apt autoremove && sudo reboot

1 Like

After doing the 1st command u suggested, I got this error:

https://www.dropbox.com/s/wt4na54yp0gew4p/img_20210904_235925425_hdr.jpg?dl=0
nonetheless I tried the 2nd command afterwards and got the same error with the nvidia 340 related stuff.

is there no command to use via the terminal to change the drivers to the open source ones they were before?

Funny, we saw this just the other day.
Try

sudo apt install nvidia-465

sudo reboot

Wasn't driver 340 bugged?

1 Like

You mean this?

https://forums.linuxmint.com/viewtopic.php?t=340402

I can't remember where I read it or was it @Aravisian that mentioned it in an earlier thread.

An earlier thread where I was trying so hard to solve a problem, I never stopped to consider whether it even was a problem (It wasn't) and I was barking up the wrong tree.
Great for popcorn.

I did this and got:
E: Unable to locate package nvidia-465

i have solved my own problem. thanks to everyone who tried and helped!

Here is what i did:

sudo apt purge nvidia-340
sudo apt autoremove

then....

sudo apt install nouveau-firmware
sudo apt install xserver-xorg-video-nouveau
sudo reboot

To make sure i had the nouveau drivers and essentials installed i did:

apt search nouveau

So yo're running the open source driver instead. Note; you can't game with that driver.

2 Likes

Oh that's okay for now... I don't play many games and for the ones I do... I dual boot to windows and play those.

2 Likes