Help please - my Zorin install no longer boots

Try: boot - How can I reinstall GRUB to the EFI partition? - Ask Ubuntu

Is your EFI partition on /sda5 or on /sda1?

My efi is on sda1

I ask because of this

The settings chosen by the user will reinstall the grub-efi of
using the following options: sda1/boot/efi,
Additional repair will be performed: unhide-bootmenu-10s use-standard-efi-file
/boot/efi added in sda5/fstab
sda5/boot/efi not empty

Ok so how do i change the reinstall to sda1?

Sorry i'm new to all this. My disk only has 1 EFI system partition. It shows
Device: /dev/sda1
Partition type: EFI system
Contents: FAT (32bit version) - mounted at /boot/efi

So im assuming this is the Lunix EFI?

The next is dev/sda2 with "Microsoft Reserved" as Partition Type. So is this the EFI for Windows?

If Zorin OS is installed on /sda5, then it should be fine... - What size is the EFI partition?

its 105mb

That should be sufficient...
Have you tried completely reinstalling Grub on Zorin OS?

OK update -
sorry for dragging this on. like i said i'm a complete noob at this.
So somehow i managed to mess up GRUB bootloader completely and when i boot Zorin i get the GRUB command line instead. I did some reading and tried to get to my desktop through GRUB command but no luck.
So i thought i may as well do a fresh install of Zorin and start from scratch. I used my Zorin USB stick and retrieved all my data files from my Zorin partition - stored these on my external HDD.
Downloaded Zorin 16 > loaded windows > wiped the Zorin 15 partition > installed Zorin 16 and it still boots into Windows as default on laptop startup.
So in windows i ran cmd - bcdedit set/ {bootmgr} displaybootmenu yes
Now when i power up laptop i get the windows boot manager but it only displays Windows OS to boot. So i hit Esc and it takes me to my BIOS Boot loader (if thats what you call it) and there i can select Linux.
It'll then take me to the Zorin Boot menu where i am able to select Zorin or Windows.

So on laptop startup i need it to skip windows and load the Zorin Boot loader - how do i do this? I checked my Boot priority in BIOS and Linux is not there. Here is what i have -

  1. Windows boot manager
  3. USB HDD:
  4. USB FDD:
  5. Network boot-IPV4:
  7. Network boot-IPV6:

I've tried prioritising HDD: Toshiba but it still boots into Windows.
I've put Windows at the bottom of the list and still boots Windows.

So is a complete reinstall of GRUB required? I'm pretty sure i tried this before and thats what broke it completely and i ended in GRUB command line. Or i may have done something wrong during installation.

I've read carmar's link on grub reinstall and have question please before i go ahead -

"Boot from the Ubuntu installation medium and select 'Try Ubuntu without installing'.
(Boot your install medium in EFI mode, select the Ubuntu entry with UEFI in front.)"

Does this mean i have to use my USB stick with Zorin 16? and how do i boot it in EFI mode like it says?

Most computers will list it as UEFI when you select what you are booting up when you tap one of ESC, F1, F2, F8 or F10 depending on your manufacturer. So that should be pretty straight forward.

Yes, the Live USB Zorin Demo.

Ok, in my BIOS i have UEFI selected instead of Legacy so that's covered. I can just boot from my Zorin 16 USB and select Try Zorin.
1 last question regarding this -
"Note : 'sdX' = disk | 'sdXX' = efi partition | 'sdXY' = system partition"
My EFI is on sda1 and my Linux install is on sda5. What do they mean by "disk"?

A disk is commonly shown as /dev/sda or /dev/sdb...
A partition would be in numerical order, and a number on that disk. If sda is your HDD and sdb is your USB stick... and each have Two partitions:
HDD is /dev/sda and partitions are /dev/sda1 and /dev/sda2

USB is /dev/sdb and partitions are /dev/sdb1 and /dev/sdb2

You would replace where it says "disk" with the applicable sda partition, for example; your EFI is sda1.

ok got it thanks.
So in the command lines
grub-install /dev/sdX
i would replace sdX with sda

I'll give it a shot thanks.

Would it be sda5?

No because i have to replace sdX with sda, sdXX with sda1, and sdXY with sda5 right?

1 Like

Sorry, yes. I misread what I read.

ok here goes...

Ok reinstalled GRUB to EFI and updated, but still not working for me. Laptop still boots to Windows and still no Linux / Zorin entry in BIOS

Does anything happen if you tap tab vigorously beginning when you see the Motherboard Splash screen?
For some it is the esc key instead... It is supposed to be tab on EFI and esc or left-shift on Legacy but I have noticed that it can (strangely) vary... I suggest trying each of the three on separate boots.