Help please - my Zorin install no longer boots

I installed Zorin alongside Windows 10 on my Acer laptop and its been working fine for about 2 years now. Everytime i power up the laptop it boots straight into Zorin and it shows the option to boot windows if i want to.
However, today i wanted to try Batocera and flashed it on a usb stick. I tried to boot from the USB stick but i got a message i've never seen before. Something along the lines of "security boot failed" with an exclamation mark icon. After hitting Enter, this message disappeared and the laptop booted into Windows 10.
I ejected the USB stick and then tried rebooting the laptop but it just keeps booting into windows as primary. I've been into Boot menu and cannot see Zorin. it has Windows boot manager as primary and then "toshiba.." something as secondary and a few others. I've reordered the boot priority so many times and even placed the Windows Boot Manager at the bottom and still cannot boot back into Zorin.

I've checked my disk partitions and cannot see Zorin on any of them. What should i be looking for?

Please help as i can't see any of my zorin files through Windows and i have all my work related stuff in there.

Try : Can't boot into Ubuntu in Windows 10 / Ubuntu dual boot - Ask Ubuntu

Thanks but that doesn't solve my issue. That guy was loading Ubuntu from legacy boot.
I also cannot find the "fast boot" option in windows - it doesn't exist on my version. It's as if my my Zorin partition has been corrupted as i cannot see it.
I have "Acer C:" partition which i guess is windows. Then i have 100MB EFI system partition; and then "74.50GB Healthy (Primary Partition)" which im thinking was where my zorin was - i can't do anything with it, all options are greyed out except for Delete Volume. It also shows as 100% free.
Then lastly i have 1GB Recovery partition.
Can someone please tell me what their Zorin partition looks like when viewed in Windows Disk Management?

Hang on I have to close Zorin and log into Win 10 .... I'll be back ....

Until Frog provides a response, all I can tell you is that my desktop dual boot Windows (7) can't read anything from my Zorin partition. I believe that is generally the case - Win cannot read ext4 partitions. If I recall correctly, for me the Win disk manager shows the Zorin disk greyed out or with diagonal lines through it.

1 Like

OK I'm back ..... theDisk 0 drive is my Zorin 16 Pro .... the Disk 1 drive is my Win 10 and the Disk 2 drive is a thumb drive ..... not a lot of info as Win will not read Zorin as carmar said .....

1 Like

Thanks for your help guys. I've made progress...
I booted into Zorin from my install USB stick from 2 years ago that i managed to dig out from my draw lol.
I did a Boot Repair. Restarted my laptop and in Boot manager, Linux was now showing up - yay! So i boot it and voila - back into my Zorin desktop. However, i can't get the laptop to boot Zorin on start up - even after setting the priority in BIOS.
Any ideas?

Thanks Bourne. I'll check it out.
Edit: i already did boot repair before you posted that first link.

You can also repair from live USB Zorin.

1 Like

Booted into Zorin from F12 and will try Boot Repair again now.

Boot Repair completed but laptop still boots to Windows on start up.
I've also noticed that Secure Boot must be disabled for me to boot Zorin. Otherwise i get the original "Security Boot Fail" message and Zorin won't boot, it defaults to Windows.
I'm wondering why this has happened all of a sudden when all i was trying to do was boot Batocera from a USB stick.

I remember one command
sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo update-grub
I used to boot f11 then choice linux and then i put this command also in bios i changed what primary hard disk must booting. When it will be linux and you update grub then you will see also windows booting. When Zorin was updated to newest kernel then grub is changed and now only using f11. I know @Aravisian is expert he help me with that also some help you.

Honestly, I wonder if Batocera changed the Bootloader file in EFI partition.
You might post a full printout of your grub file using the no parse tags in the Reply Box toolbar </>
IF that all checks out... the only thing I can think of is to delete the EFI partition and make a new one, then reinstall Grub and Re-install the Windows Bootloader - which is a pretty big (and a bit risky) undertaking. It would be easier with just Zorin...
It's a good reason to not try testing other Distros on your primary use machine - a lesson I have stubbornly learned the hard way several times.

1 Like

Possible that Batocera did, because the issue started after this.
The boot repair actually failed. I'll post a link to the file when I'm back on the laptop.
Thanks again for help

Have you checked that Windows has not somehow re-enabled the 'sleep' mode of the hard drive? This is what keeps Windows 10 booting fast - you have to go into Power Management/Advanced and turn the 'sleep' mode of the Hard Drive off.

1 Like

Yeh, sleep is off

Reading your earlier posts about Fast Boot not in Windows, it isn't, it is in the BIOS, but if a newer machine then there is a Security setting that has to be turned off for you to enter the BIOS! Only learnt of this feature myself yesterday via LUG (Linux User Group). Just to add I barely use Winblows these days! :wink:

Boot Repair Failed in Zorin -
"An error occurred during the repair.
Error: no grub*.efi generated."