Help trying to install software

So I'm trying to install the latest version of Okular (21.04.2) on Z16 but I can't. The PPA repo for Ubuntu 20.04 has an outdated version of the app with inferior UI and missing features. I used to use the Flatpak version but now I don't want to use Flatpak. I tried to manually grab the .deb file but then it doesn't install the dependencies and it won't work. I tried adding the Kubuntu backports PPA from here but that did not really work as it installed an outdated version yet again.
I don't understand why I cannot install the latest version of the app by default. The flatpak version ran just fine (I used it on Z15.3), so I don't know why the Ubuntu repositories serve such outdated packages for Ubuntu 20.04. It's not like Ubuntu 20.04 is old.
So how can I install Okular 21.04.2 on Z16?

I looked at Okular page at KED.
https://okular.kde.org/download/
It looks like the version they give you is 19.12.3 for Ubuntu 20.04 (which Zorin 16 based on).

Build from the source yourself?
I did that for phpMyAdmin recently to overcome outdated PPA issue.

Ouch, I was hoping it'd never come to that :smiley:

It is really not that hard :smiley_cat:

It is a very useful skill to have. You can also build a driver this way for peripherals which is not supported in kernel. I did that a few times when I was playing around the latest USB WiFi dongle (8812AU, that was).

2 Likes

Is there a better way to force users into accepting Snap and Flatpak?

In case you do not want to follow FrenchPress's advice, you can also try the below method. I agree with FrenchPress's advice, though. Installing from source may look daunting at first glance, but really is very easy.
Alternate Method:
Try installing the dependency:
http://archive.ubuntu.com/ubuntu/pool/universe/c/cross-toolchain-base/libc6-amd64-cross_2.33-0ubuntu5cross1_all.deb

It will warn that an older version is available... Whatever...

Then Ocular:
http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu/pool/main/o/okular/okular_21.04.2-0ubuntu1~ubuntu21.04~ppa1_amd64.deb

The latest Okular (21.04) is the Latest Unstable Version listed for Hirsute Hippo. I did not want to test that this all works by installing it on my Z16. So, take the above suggestion with a grain of salt. Or a system back up. Or something. Plus, the Latest Unstable Okular MAY demand a higher kernel, too.

1 Like

I really appreciate the suggestions but I'm a bit lost. Building the source code for this app is such a daunting process. I'm having a lot of troubles with it. I'll elaborate on it.

This method did not work. It still said is missing dependencies.

It's not difficult but it's messy, confusing and time consuming. To build this app I need to have +50 dependencies. It wants me to go and individually grab all of the +50 dependencies. I tried to do some unholy tricks in Synaptic to download only the dependencies but that didn't work as well.
The process of building this app is so unintuitive that I feel like I'm doing it wrong. On the Okular page to build the app it casually says you need to have a compilation environment set up. Ok but how? I have the basics but how am I supposed to grab all the +50 dependencies on my own. I tried looking up online but it seems like that I have to bite the bullet and install all of them one by one.
I am a somewhat experienced Linux user but I feel like I'm missing some huge parts of the puzzle here. The build instructions on the KDE Okular page say almost nothing. Is seriously grabbing all the +50 dependencies the only way to do it?

the -y tag will grab all the dependencies, fifty or ten or one hundred, in a normal installation. While this is not necessarily helpful in this immediate case; it does highlight that installing a large number of dependencies can be done very easily.

I am sorry my method above failed you with a dependency hell... We all know what that is like. But we are also not out of tricks, just yet.

As Hirsute Hippo Repo contains this stuff... What would happen if you temporarily added the Hirsute Ubuntu Main Repository?
Then used

sudo apt install -y okular

Let's try it. First- back up your system. As I said above, I am not sure about the kernel requirements for what you are trying to do.
Open Software & Updates from your app menu.
Other Software Tab
Click Add
Paste in
deb http://us.archive.ubuntu.com/ubuntu/ hirsute universe

Click Add Source and enter your password.
Now, open a terminal and run

sudo apt update

sudo apt install -y okular=2.33

IMPORTANT
If successful, go back into Software & Updates
Other software
Highlight the line for
deb http://us.archive.ubuntu.com/ubuntu/ hirsute universe

and click REMOVE. IF this step is not done, you will break Zorin OS on the very next update.

With all those dependencies, no guarantees that it may not break something.
And really, going all the way up to the Hirsute Hippo Unstable version is kind of risky.

Your Last Option is:
Use the Flatpak for this one. While many of us disagree with Flatpak and its principles, if it is what serves you best right now... It seems a perfectly viable option. Not all bad things are always bad.

I really appreciate your step by step guide. That was a promising idea. Sadly it didn't work. It was not cool with installing the package and it was also still an older version... sigh.

Oh damn, after all this I have to download the Flatpak version... that's just extra pain. Two tricks occurred to me now. They are unholy... but I'll be happy as long they work.

Thanks Flatpak
image

I gave up. None of the tricks worked. I tried everything. And actually I did figure out the build process but it would've taken me another hour or so to set that up and even after all that, more bloat would've populated my disk and there was no guarantee that it would've worked. Building KDE software from source is a huge nightmare... jesus. I just wanted to annotate my PDF file :'(( I guess I should be thankful for Flatpak or else there I wouldn't have been able to install it altogether. But thank you everyone for your support :smiley:

1 Like

I understand y our pain. Sometimes, I have a deep preference or a need for features introduced in a later version. I have been very fortunate that I have not had to resort to Flatpak or Snap to accomplish it.
OR maybe not fortunate as I am stubborn, that I went through a couple days of patching and coding. Whatever.
KDE applications are built in QT, not the gnome toolkit, so it makes sense that they would be trickier to mesh with a gtk system.

1 Like

If you do not mind using a proprietary app, I highly recommend Master PDF. The older version 4 will let you editing PDF file for free. We have been using it for a couple of years and are quite happy with it. You can download deb installer here:

Hint: Do not take "upgrade" when prompted. Stay with the version 4. You can change the frequency of update check in the settings for "never".

1 Like

Thank you for the recommendation but I prefer to use Open-source and Libre software. However I took a quick look at it and it seems that some features are locked behind paywalls as well. Okular and Libreoffice cover all the features that I'll ever need and they are free and open-source.

1 Like

I certainly respect your viewpoint.
Nothing is perfect in the world, and we all have to make a compromise somewhere. In your case, it is a Flatpak and in our case, it is a MasterPDF :slightly_smiling_face:

1 Like