Help uninstalling veyon to start over

I'm using Zorin OS 16.1 Education on a core 2 duo (old machine used at school).

I wanted to get started with veyon on the client computer but when I use the installer in the software store included in the os, the veyon version is not the latest one and when I install the veyon configurator, I'm unable to get the the service started.

I then tried to install veyon from the download on the website but the master gets also installed I only needed configurator to get the service started on the client. so I remove that install. (the service did started with the latest package from the site)

I then tried, without knowning much of what I was doing, to install veyon using make install as shown here: GitHub - veyon/veyon: Cross-platform computer monitoring and classroom management > veyon on linux and it did install both configuration and master but it won't open either with an error stating that the program won't run due to previledges now, I'm not able to uninstall it

any help is appreciate it I really want to try this out on 14 machines.

If you installed using superuser, which is almost required on all software, you will have to use sudo in order to run the application as well as the service, unless developed to use the user permissions. Try using the terminal to initiate the application (sudo veyon).

1 Like

Can you ensure that Veyon has not been installed as a Snap or Flatpak package, first;

flaptpak list

snap list

If it is, you can use the package manager to remove it sudo snap remove... or sudo flatpak uninstall...

I would recommend using Synaptic Package Manager for in-depth and thorough package removal:

sudo apt install synpatic

Launch Synaptic, then click search. Enter veyon into the field.
Right click any packages that are Veyon and select to Remove Completely. Click apply when finished selecting.

What is available on Zorin appears to be Veyone 4.3.1 - You probably only need the install for veyon-master but I will include the below to be thorough:

sudo apt install veyon-master veyon-configurator veyon-service

Really, this package should work properly upon installation.

2 Likes

Thank you
I'll try the synaptic route.
what I ended up doing was to re-install using the repository, then updated, and then

sudo apt get install veyon

it did install configuratior and veyon master, but since this was a student machine and the service did start normally and was able to be seen by the master, I left as is and moved on.

I will try the synaptic route in hope that it would completely remove whatever I ended up installing when I did it with 'make install', at least I know that with the repo option and installing from the cli I should be able to get that working again.

Thank you all for the replies :). enjoying zorin with dual boot and I'm about to present that to the school, I hope they like it as much as I already do. cheers :slight_smile:

2 Likes

Please report back how it went :slight_smile: