Hi im trying to install diferent a os

I'm trying to install ubuntu but it always errors I have tried different usb drives reinstalling the os and even tried to install windows to see if it would work but it always errors

in ubuntu installation the error is
falled to start Ubuntu live CD installer.

and in windows the error is
[sdc] no caching mode page found
[sdc assuming drive cache: write through

nvidia gpu 000:06:003: i2c timeouterror e0000000
ucsi_ccg 3-0008: iec_transfer failed -110
ucsi_ccg 3-0008: ucsi_ccg_init failed - - 110

This sounds like the EFI partition is either corrupt or damaged. Creating a new EFI partition after wiping the existing may resolve the issue as long as the hard drive is ok otherwise.

These are just informational... some USB sticks don't have the ability to do drive caching. I have that same message on a couple of USB sticks that I use.

Some Nvidia cards don't have a USB Type-C interface, yet still try to load its i2c and ucsi_ccg drivers. That shouldn't affect the operation of the GPU.

Perhaps @Aravisian knows of some way of preventing the i2c and ucsi_ccg drivers from loading for the GPU.

Perhaps by creating a /etc/modprobe.d/blacklist_i2c-nvidia-gpu.conf file with this content: blacklist i2c_nvidia_gpu and blacklist ucsi_ccg
-- or --

sudo touch /etc/modprobe.d/blacklist_i2c-nvidia-gpu.conf && sudo echo "blacklist i2c_nvidia_gpu" > /etc/modprobe.d/blacklist_i2c-nvidia-gpu.conf && sudo echo "blacklist ucsi_ccg > /etc/modprobe.d/blacklist_i2c-nvidia-gpu.conf

If your Nvidia GPU does have a USB Type-C interface, doing the above will disable it, but you won't see the error messages in the logs anymore.