Hibernation fails

Hi,

I am used to using the systemctl hibernate command to hibernate my Asus laptop. It has been working great, but for the past week, it wakes up immediately from sleep. There seems to be a busy resource that prevents it from going into hibernation, but I can't figure out what it is.

Any ideas, please?

Thanks, guys


There it would be good to know what Process ... What stands in the Line under Your marked One? I mean, where stands ''Freezing user space ...''?

Freezing user space processes failed after 20.002 seconds (1 tasks refusing to freeze, wq_busy=0):

Here is a more detailed log:


Okay ... There stands ''start failed with result 'dependency' ... That sounds not very specific.

Then stands there ''Failed to put system to sleep. System resumed again: Device or ressource busy''

Maybe there is some Background Process that blocks the Hibernation.

I've also had many issues with hibernation despite following precise instructions here and elsewhere; now I don't know the specific solution to your problem, but following this guide verbatim worked for me, see if it does for you too:

Thanks for your reply.
For some reason, hibernation sometimes works. I can't figure out why!
To be honest, I won't destroy my 32GB SWAP partition when I'm not sure whether it will solve the problem. I may create more issues.
Moreover, it has been working great for several months. I can see my SWAP partition contains data when it goes into hibernation, so it does not seem to be a configuration issue.
I assume some kernel or driver update created the problem, but I'm not 100% sure.
I'd like to use the command "dmesg | grep xxxx" to identify the busy resource, but I don't know the process name.

Hi,

I used that command to find the task that prevent my system from going to sleep : dmesg -T|grep Freez -A4

[mer. juil.  3 19:22:21 2024] Freezing user space processes
[mer. juil.  3 19:22:41 2024] Freezing user space processes failed after 20.006 seconds (1 tasks refusing to freeze, wq_busy=0):
[mer. juil.  3 19:22:41 2024] task:pool-tracker-mi state:D stack:0     pid:79118 ppid:1433   flags:0x00004006
[mer. juil.  3 19:22:41 2024] Call Trace:
[mer. juil.  3 19:22:41 2024]  <TASK>
[mer. juil.  3 19:22:41 2024]  __schedule+0x2cb/0x750

However, I can't find out how to solve the issue. I can't find any pool-tracker-mi task.
I've been trying to kill it with its ID (sudo kill -9 79118), but still the same problem.

Any idea?

Thanks for your help !