Hiding and disabling airplane mode

Hello how do you completely prevent airplane mode from activating? I need to get rid of the icon so my grandpa stops clicking on it by accident.

I just need that function completely hidden from the desktop.

I looked this up and couldn't find anything, so somebody else will have to help you with this. Just know, I tried.

I checked my Zorin 16 Pro.
But I did not see any such icons.
Are you using Zorin Lite?

I have mine shut off, but it seems to just start up all by itself on reboot for some reason.

It seems I do not have an airplane mode - my system is desktop.
This must be a laptop only setting.

Correct FrenchPress, its a feature in notebook computers. And a lot of notebooks have hardware level switches that are activated by holding down the FN button and pressing a F-key. And there is usually a WIFI on/off function in one of the F-keys.

1 Like

Just firing up my Elitebook which also runs Zorin 16 Pro.
Now I see the Airplane mode in settings.
But there is still no icon for Airplane mode in taskbar.

So I am wondering if OP was talking about Zorin Lite with XFCE desktop.

I just fired up my old Acer Aspire which is running Zorin Lite 15.3.
I still failed to see the Airplane mode icon in taskbar.

Can you take a screen shot to show us which icon you are talking about?

1 Like

Correct, Airplane Mode is in Gnome, not in XFCE.

1 Like

But I still cannot see the icon for airplane mode OP was talking about on my HP Elitebook with Zorin 16 Pro.

Where is my airplane :airplane: ?

1 Like

Some notebooks have the switch as Fn+F12.
Some users report being stuck in airplane mode no matter what they do.

Sometimes, user settings in GUI can be made to be too simple and neglect functions the user needs access to. When I first started using Zorin OS, it was on Core with Gnome and Airplane mode was one of the major thorns in my side. I had to constantly argue with it.
Switching to Zorin Lite resolved that issue for me, so I never looked further into it.

I could be wrong here, and likely I am...

But users might only see an airplane mode toggle, if their notebook has the hardware switch built in.

1 Like

That is an interesting point.
I really wish OP will be back to this thread and show us this mysterious "airplaine mode icon" in the screenshot.


Hello my f12 button acts as airplane mode. Is there anyway to get rid of this function? I want to make the f12 button useless. And also on laptop computers there is a setting for airplane mode in the settings. I want to customize the menu so the is no airplane mode toggle.

The laptop i have has a hardware switch and a switch in the settings menu.

The airplane mode button is a hardware function, which is governed by your computer's bios. Most computer bios won't allow you access to the function keys for modification. However, if your bio's has a magic unlock command to show the hidden settings, maybe, but thats a big maybe.

Go into your BIOS and look for anything which you can modify for the airplane mode key.

1 Like

Oh well. Somethings just can't be changed.

Now I understand. Thanks for this explanation.
For whatever the reason, none of my laptops have this :airplane: button on the keyboard.

To prevent your grandad to touch this key by mistake, you can cut a small label and write a "forbidden sign" :no_entry_sign: on it and stick it to this problematic key.

I use a lot of stickers on my keyboard to make my touch typing easier.


Three Dimensional stickers.


I never thought of this... Genius.
Can I mark your post as solution? You just solved a problem of mine.
(I probably won't be using Hello Kitty Stickers....)