High Refresh Animations / OS Movement - Zorin 17.1

This is probably a weird question, but I run this OS on both my laptop and my desktop. My laptop runs the "jelly mode" animations at 120fps (max the display supports) but my desktop with a 240hz monitor only runs the animations at 60 seemingly. This isn't just relegated to jelly mode animations though, window dragging is also much lower than what my laptop does. My mouse on desktop moves at 240fps for example, and games run well above 60fps without an issue. It's like the OS needs to be told the hz to run at or something? Does anyone know how I can fix this? Window dragging looks really awful because of it. (yeah, I'm spoiled, I know)

Have you checked your xrandr settings?

https://www.reddit.com/r/linux_gaming/comments/pg3wqt/my_165hz_monitor_is_not_being_detected_as_such

You will need to change the script from 144/165 to 240.

That's a bit different of an issue. That person couldn't get things to go above 60 from the sounds of it. Regardless, I actually just figured out the difference. I'm using Wayland on one and X on the other. It seems that animations run as fast as the monitor can render on Wayland and are 60 capped (for OS animations only for whatever reason) on X11

Thinking on this a tad more, I might still try it anyways, because I can't use GSYNC with Wayland. I'll report back with whatever I find.

Just found this nugget but it relates to Unity desktop in Ubuntu:

No go, setting display settings manually with xrandr results in the same situation. It seems the only way to get full fps with animations is to use Wayland. RIP GSYNC

Same result. Everything works at high refresh except OS animations. Thanks though!

What for Hardware Spec's have Your Machines? Especially the Graphics Cards?

Did You have checked the Display Settings:

Do You have Fractional Scaling active?

1 Like

My hz rate is 240 and my specs are:
RTX 2060 Super
Ryzen 7 5800
32GB DDR4 3200mhz

A NVidia Card ... NVidia and Wayland have some Issues. The Situation changes in the current time but that is for Zorin unfortunately not relevant at the Moment. Did you tried to change to Xorg and test it?

What NVidia Driver do You use?

And what is with Fractional Scaling? Do You have this activate?

1 Like

I actually find that the issue largely goes away with Wayland. X11 is where the animation lag occurs. The only thing preventing me from using Wayland is that it doesn't support GSYNC seemingly. I also discovered that some Steam games only work with X11 as well though. As to fractional scaling, I'm not using it (i.e. it's off). I think considering how much gaming stuff Wayland breaks, I'll just have to stick with X11 and deal with the fact that animations are 60 locked for whatever reason. It's really not that big of a deal, just nice when animations are smooth is all.

1 Like