Horizontal Workspaces (Uncentered view on Show Activities)

Hi!

I am using the built-in extension Horizontal Workspaces (Zorin OS 16 Core fresh installation). It works nice, but when you press Super+S (Show the overview) there is an empty space on the right part of the monitor. This zone was occupied by the sidebar of the vertical workspaces. So now the overview of my open apps looks uncentered and unsymmetrical. There is any way or gnome extension to fix it?

Thanks in advance :slight_smile:

Hi and welcome to the forum :slight_smile:
Are there any chances you take a photo of the screen?

I think I do not have an enough imagination to visualise what you have described :sweat_smile:

2 Likes

Ahhhhh, yes, for we step into a world of pure imagination, imaginating what, I do not know, for I can not see.

2 Likes

Hi!

Thanks for your welcome/answers! I did some screenshots, I hope it helps.

Vertical Workspaces


Horizontal Workspaces


Actually, in both cases the "windows" are uncentered, right? But with horizontal workspaces activated the empty space is bigger.

1 Like

I am using a default vertical workspace and my desktop looks exactly like yours.
I do not have any GNOME extension.
I hope someone with this knowledge could assist you.

2 Likes

Looks normal to me, but then again, I don't use multiple workspaces, so my opinion doesn't hold much in this aspect.

1 Like

I figured out what's going on... but I don't know how to fix it (yet haha)

I'm using the Dash To Dock extension, if you disable this extension, then apps overview looks centred. Even if you use Dash To Dock but you pick right/left instead of top/bottom positions, apps overview looks centred and nice also.

So the thing is figure out how to remove the empty space on the apps overview that apparently, Dash To Dock or Gnome or Zorin or someone (sorry) is saving for the right/left Dock.

Here are some examples about what I would like to achieve (in terms of centring apps overview):



2 Likes

While reproducing the problem, can you run journalctl /usr/bin/gnome-shell -f -o cat & and report the results here?

2 Likes

You could attempt to shut off the workspace previews, which are what takes up that vertical bar in the right. I'm wondering if this will help. Should be in the overview options.

3 Likes

Many thanks for your answers @Aravisian and @337harvey.

Your approach fixed it! :DD

  1. Activate Just Perfection extension.

  2. Open Just Perfections settings using Extensions and disable "Workspace switcher".

Final result:

Thank you very much everyone for spending time with this issue :slight_smile:

1 Like

Yes, you had such a niche request, I didn't know how to solve the issue. But as with all things Gnome, if there is something you don't like, chances are there is an extension out there, to change things so you do like them.

2 Likes

It was a setting, actually. @337harvey figured it out.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.