How access plugged in USB stick

Also if you can tell me, how do i access a plugged in usb flashdrive. Ive tried formatting and unformatting it, Ive tried cleaning all the files off the usb. It is a sandisk 3.0 256GB.

USB sticks tend to be plug n' play, they should automount once plugged in.

Please open a terminal and run

sudo apt update && sudo apt dist-upgrade

Ensure that all packages are up to date.
Then we can check your automount settings.

Im just not going to use zorin

Every time i fix something i turn my computer off and on again and it stops working

On this subject, I wonder if someone can explain the following: I purchased a new PC Win 10/11 in July, and formatted a couple of old USB2s for re-use in the future. I then installed Zorin 16 Lite as sole OS. Recently I formatted another USB2 in Disks, but when plugged in it did not appear in filing system, but did in Disks. Eventually in Disks I created a new partition for the whole USB, and it now appears in Files menu, and has been re-used. The USBs formatted in Win10 worked immediately when plugged in. It would seem that formatting in Zorin removed the normal partition of the USB.

The Format in which the disk is Formatted affects the drive. If the device does not support that type of formatting, you cannot access the drive from that particular device.

USB Sticks can also be fickle. I have formatted many in Zorin OS that were picked up without any trouble in Windows.
You may have just hit some bad luck.