How can I disable disk checking at boot?

is there a way to disable it permanently?

It is very annoying that when you turn off the laptop with the button you have to wait a lot for the next boot

Hi, disk checking is not a part of the normal boot sequence.
If you get it all the time your disk might be on its way out.

oh I did not know

is that the system has been working wonderfully and starting without any problem but today I turned it off with the button and now to start the disk analysis appears (/ dev / sda5 Recovering journald) and the truth takes a long time (more than 15 minutes)

but I have been able to skip it by pressing Esc or Tab, the truth is I don't know which of the two it is, but it works so that it starts faster

You should check the integrity of your HDD/SSD with Disks app. HDD/SDD is a consumable not a permanent item.

I have 2 bad sectors that I already repair

and you still experience this constant check disk?

No, the system was working very well then I turn it off with the button and now the disk check appears every time I turn on the PC

Are you dual booting?

No, I only use Zorin on my disk

OK.
I am at my wit's end.
Let me invoke @Aravisian for help.

What does the disk checking look like at startup?

it's a black screen with this message

/dev/sda5: clean, xxxxxxx/xxxxxxx files, xxxxxxx/xxxxxxx blocks

using Tab or Esc this stops and the system boot normally

I think I also have that, @FrenchPress do you have this? The plymouth theme hides it tho.

If you press and hold the power button to force shutdown the computer, it bypasses the proper shutdown procedures. This can cause errors on the disk. If data is actively being written to the disk when you do this, it never completes.
Disk checking prevents those errors from compounding.
The best way to avoid it is to shut down the computer properly, using the ShutDown button from the app menu.

2 Likes

that's what i was, force shutdown

before that the system started without any kind of flicker or error

but now every time I turn it on, that appears, what can I do?

Let it run its course. And remember not to shut down that way again. :wink:

1 Like