How can I fix the overview background not updating accordingly with my theme?

Upgrading my desktop, to ZorinOS17, and that happened.

Also not sure if it is related, but some apps still use the old theme
image2

When I see it right You want to use Zorin Dark Purple. Did You tried Gnome Tweaks? If not You could try that. You can find it in the Gnome Software Center or open the Terminal an type sudo apt install gnome-tweaks

When You installed it open it and go to the second Menu Entry. There You have the optical Settings. There You should go to ''Shell'' and choose there ''ZorinPurple-Dark'' and then the Background should changed. Here a Screenshot:


i manually changed it to something else then changed it back and I still have the same issue

3
Also I noticed like the quick settings too only recognize the default blue light theme

So, You have still the white Background even with ZorinPurple-Dark? And the blue Accents? You could try a Reboot of Your PC. Maybe then the Changes will work.

What else ... Open the Terminal and type sudo apt reinstall zorin-appearance (that will reinstall Zorin Appearance). Reboot Your PC and look if it works. Then You could try sudo apt reinstall zorin-os-desktop (that will reinstall the Zorin Gnome Desktop).

Zorin OS 17 needed to adapt to the New LibAdwaita libraries that Gnome introduced in order to lock distros into using the Gnome default Adwaita themes (all two of them. Light and dark).
Because of this change, this has introduced some new complexities into theming on GTK4.
This introduction was met with great resistance by the GnuLinux community as System76 opted to create Cosmic D.E. Solus devs suggested making a new D.E. in order to avoid using Gnome in future. But Gnome is unrelenting and forced the package through in spite of the stakeholders protests.

Accents are a major part of how themes and LibAdwaita will interact.
This is an integrated part of the LibAdwaita API - which already is causing conflict with Zorin OS users that try to use a different theme of their own choice on their own machine and their own desktop.
Rather than displaying an accent, the display is showing a gradient of both colors. This is not due to users breaking anything or performing any discreet customization.

The short of it is; there is much work to be done to try to work with the new libraries and API's Gnome has introduced in order to limit and prevent user themes.

tried that, rebooted, even tried changing the theme around afterwards, still didn't work

this is still the case, might be something related to the old gtk theme

My laptop did not have this problem during the upgrade, same theme and all. Probably something I have done. My guess is I need to reinstall the part of the theme that's causing that but I reinstalling the appearance and the desktop to no avail.

The upgrade includes the transition from Zorin OS 16.3 (non-LibAdwaita) to Zorin OS 17 (LibAdwaita).
It is possible that you have done something such as trying an independent theme. But there is the crux of the issue if you did do so. Is it wrong?
If so, why was something that was not wrong for the past twenty years suddenly wrong today?

possibly, also when I change to light theme the wallpaper also changes.

is there any way to like just outright reset the config and reinstall all the zorin theming stuff?

Have you added any third party repositories/ Themes?

If so - you may remove them (though not a Necessity for the vast majority of themes).
If not, remove your home .config directory from system access:

mv ~/.config ~/.config-bk

Reboot or log out and back in and all your desktop configurations will be restored to Zorin Defaults.
The reason we moved the folder to a bk (backup) instead of outright deleting it is in case you still have configurations in there that you need and want to retrieve.

I tried that, still same problem..

What You could try is open the Software Center and uninstall the Zorin Purple Theme, reboot Your PC, install it new, reboot again and then try if it works. Maybe the Ghost in the Machine will accept that.

currently trying out downgrading to Zorin 16 (using timeshift) and reapply the upgrade and see if the issue persists. I'll try that next

1 Like

I am going to reinstall Zorin 17 actually. Thank you for all of the help and suggestions though!

1 Like