How can I get permission to save a file in GUI?

Hi,
I'm not sure if I have been told this before but it has gone out of my head if I have :slight_smile:
I'm in apache2/sites-available and created a file in nano. I try to save but told I have no permission to do so.
I went into terminal and did, sudo -i command thinking it may allow me in the GUI but no go.
I just don't know enough yet!
Please guide me to get perms every time I want to save in nano as I use it a lot.
As far as privacy is concerned I am the only one within a bull's roar of this box so no worry about sneaking eyes etc.
Thanks oz

You could do sudo nano <name-of-file> and that would give you access to edit files inside protected directories. That would be the more proper way to do it.

From the file manager, you could right-click on the file or directory and then within properties there should be an option to set permissions. I'm not entirely sure about this method but I seem to remember such an option exists.

Just a note: the issue here is not so much about privacy but security.

HI Thanks for the reply.

Yes I ended up doing it creating, updating, copying etc in the terminal, though my habit is to do most things in the GUI.

I keep forgetting about the Permission tab in properties.

I suppose the most confusing thing of Linux for me is the permissions.

Seems like so much I want to do, I run into the permission thing. I am fine in terminal however I do need to do things in the GUI but forever getting blocked.

For example I am wanting to do a Backup through GUI but get I don't have permission at that drive. Chose 2 drives and the same result.

Giving up after 5 attempts. Error: Error opening file “/media/david7500/2TB Seagate/$RECYCLE.BIN/duplicity-full.20221214T194138Z.vol1.difftar.gpg”: Read-only file system

When one is trying to 'unlearn' learning something for example Windows which is so simple, to replace it with something quite foreign, it can get very confusing, and frustrating to say the least. It's like a horse on a racetrack as opposed to a horse on a steeplechase with jumps every so often. I strange that there is no way an admin user cannot set themselves up to access all drives, folders and files except maybe system folders,files in GUI. Why have GUI at all if one has to repeatedly revert back to commands in a terminal..

Don't get me wrong, I have spent my IT life with commands and code so get that aspect of it, however also like the visual GUI. Like driving a tractor but want to drive the Caddie.

Anyway, just a rant, I'm really enjoying the challenge of it all otherwise wouldn't bother.

Appreciate all the help I get here too but aware I could be driving you all batty.

Have a great day :slight_smile:

1 Like