How can I install the Intel microcode?

Done, I already installed Zorin Os in UEFI and a few things changed, animations are smoother, video performance improved, and the system feels more stable overall (y ahora ves el logotipo de mi fabricante junto al de Zorin al Arrancar :open_mouth:)

But the screen still flickers on boot and my PC still writes dots if I put it in Hibernate

1 Like

I do not think so.
What I understand is that this mitigation related slow down would only affect commercial servers and not average users.

2 Likes

What gpu do you have ?

@Bourne
This thread even does not concern you.
You have AMD CPU not Intel CPU.

Intel Corporation Skylake GT2 [HD Graphics 520]

My processor is Intel not AMD.

But the image you have deleted showing AMD CPU as your own (moderators could access to your deleted postings).
I am puzzled:

Actually, it is not just mods who can see it. Anyone can, even people who does not have an account can see it. Which actually makes me feel confused. If others can still see your post, then why is it termed as "delete this post" ?

3 Likes

"For the record" as we say.
I usually do not bother to see the deleted content.
But in this case what @Bourne said in the second message was contradictory to his first. Hence, I brought it up. Otherwise, my reply to his first posing makes no sense.

1 Like

It shows GPU to me

@Jesusito, do you have green blocks ?

sudo apt purge xserver-xorg-video-intel

https://itectec.com/ubuntu/ubuntu-ubuntu-20-04-graphics-driver-problem-duplicate/

1 Like

No, just the problem when booting the system

OK, I see it now. My bad :sweat_smile:
I got a bit confused.
I only saw GPU-Z part he posted.
Might be a time for me to change my prescription glasses :face_with_monocle:

But everything is OK after booting, no?

I wouldn't consider the flickering screen to be a severe problem as long as it happens only during the splash screen and there are no other screen problems....The "period key" problem is a bit more concerning.....

2 Likes

I suspect a hardware issue, if not a BIOS issue.
If the laptop is no longer in warranty and @Jesusito does not mind to open it, checking the internal cable connection might help.

It can't be a hardware issue either, @Jesusito mentioned in a previous topic that they tried other non-Ubuntu distros and Windows but they did not encounter the problem there. See here....

Right, I forgot that.
Then the BIOS/firmware issue is the only thing I can think of.
I remembered that I had to flash the firmware of my Logitech Trackpad (in Windows!) before I could enable its tap to click function in Linux. Since that experience, I always have one bare metal Windows for a firmware update purpose.

Other than that - I have absolutely no idea.
I've never seen such thing in my system integration experience which spans for 2 decades and half.

1 Like

@Jesusito

I think your best course of action is using a distro like MXLinux which does not give you this keyboard problem.

We are completely out of idea how to solve this issue in Zorin.
Considering you have been struggling with this laptop since April last year, I think it is a time to move on to other workable solution.

[edit]
I selected @Winged1's posting as an answer to the original question.

All Linux distributions that I have tried, including MX Linux, have this keyboard and graphics problem.