How can I make window corners square?

I'm using Zorin OS Lite with the XCFE desktop. I installed the Redstone theme (https://www.opendesktop.org/p/1013482/) which is supposed to have square corners, but almost all of the corners on my desktop are still rounded. The exception is the Settings menu for some reason. How do I fix this?

That theme is supported on gtk 3.18 while Zorin OS 16 is using gtk 3.24

I would recommend testing a Different Known Theme that has Squared Corners before trying anything else.

In Lite (XFCE), the windows borders and corners are handled by the XFWM4 Window Manager.

1 Like

For anyone having the same issue:

  • Go to Settings > Settings Editor
  • Select the xfwm4 Channel (it's probably near the bottom)
  • Find the "rounded_corners_radius" property, and set it to 0

This worked for me

1 Like

Brilliant. I just followed your steps and easily found that. Embarrassingly, I did not know that setting was there.

Thats the trouble with XFCE, lots of settings. You don't have that problem on Gnome :rofl:

i would rather have the problem of not knowing the setting was there - than not having all those settings there.

1 Like

This is my argument for KDE Plasma. :sweat_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.