How do I change the Interface Font without affecting other applications in Zorin OS Lite?

Whenever I select an 'interface font' using Zorin Appearance or 'default font' in system settings, the font gets applied to everything. I could change the font for the text editor and the terminal but I could not do the same thing in Google Chrome and it is not very productive to change the font in every application one by one. Any help would be appreciated.





Hello there! :smile_cat:

You can change Google Chromes own font in Google Chrome browser itself. Go to Chromes settings, then click Appearance.

Customize Fonts

I hope that this helps! And don't forget, you are awesome everyday. :grin:

The problem is they don't work...
If you see above the firefox screenshot.
The font settings are the default ones but they still use the interface font, just like google chrome.

Another option is Flatpaks. Since we all know Flatpak operates in its own sandbox, that means, its supposed to be independent from the rest of the system, correct? So, it is logical to assume, if you install the Flatpak versions of those APPS, they shouldn't use the systems fonts, themes, and whatever the heck else.

My two cents...

1 Like

Ah..A wise solution indeed!
However, I will still be waiting for a proper solution since flatpaks and snaps take a long time to open and consume a lot of space. Until then I will bear the issue.

1 Like

Are Browsers the only application showing this problem?

No, It happened in all apps like the terminal, the text editor and synaptic package manager but I could change thier font in their respective settings.

And this is on Core, right? I'm not sure on Core. I just tested this on each of those apps, but I am using Lite and using Xed, not Gedit. I had better results.
Are you changing the system UI font in Gnome Tweak Tool?

No,This is on Lite...I will be honest. I did not even enter GNOME for a few days because I like my new XFCE desktop very much. I think it was Gedit or Mousepad...I changed the font using Settings manager and also tried with Zorin Appearance. The terminal was XFCE Terminal.
Add Krita to the list too...along with Synaptic and the two web browsers and the text editor and terminal.

Can you please name the fonts you are using?
See if I can duplicate... I do not have Krita, but I have the rest.

The font's name is DisposableDroid BB.
I am using the Regular variant as default.
Note: The font is a little small so I had to increase its size to 13. In Synaptic package Manager, the font itself had not changed but the it's size increased. In Krita too, the font did not change (in some parts) and the size increased (but in other parts the font changed as well). This happened only in Krita and Synaptic Package Manager, s far. In other applications the Font changed completely.

Note 2: Look at my screenshots above in the OP. They may be of help.

I installed the font and it is showing in in XFCE terminal, all dialog menus, Chrome Browser, Firefox Browser... I have not tested it in Synaptic because Synaptic is run from ROOT and I installed the font in ~/.fonts, not in /usr/share/fonts....

I am at a loss as to why your experience is different. I did need to reload the browsers to see the change take affect, but I am sure you did that.
And you are right... this puppy really is small...

I also know you avoid Snaps and Flatpak... but you may double check that, in addition to checking where you installed the font.

I think you did not understand the question clearly... I do not want the font to appear in the applications. I want it to appear only in the interface.

That is a bit... picky... isn't it?

To get the level of customization you seem to be seeking, you may try a custom gtk.css file in your ~/.config/gtk-3.0

By the way... What Zorin-Appearance calls the "interface font", the regular Settings calls "Default System Font."
The GUI applications you see are all user Interface.

I understand...well, is there a way to change the font of the web browsers I mentioned and of Krita? I mean I could change the font of other apps like the terminal and the text, why not them?

@StarTreker 's post suggestions did not work?

This one?
I already tried it.. It didn't work. The font settings of Firefox don't work either. Forget Krita, I used it only for creating icons which is an abandoned project now.
And if you are talking of the flatpak suggestion, then I already mentioned that I won't be using flatpaks and snaps.

I just tested Chrome Browser and uhh... the fonts changed. But then they refused to change back.
I'd rather not tie myself into a knot with Firefox at the moment...

Yes, I had as well, but still worth covering....

1 Like

The beta version of Flatpak Chrome has the same problem. Ironic! since flatpaks and snaps don't respect the gtk theme neither does it respect the cursor theme.

I could not locate where the font was installed. I just extracted the archive and then double clicked each variant of the font to open it and clicked on the install button present on the top right.

I followed your link and downloaded it as a .ttf, which I then moved to ~/.fonts

I do agree with you that I am confused as to your intent. The UI on your screen composes the UI of the applications.
The interface is essentially Your Window into the operation of the computer.

The tip I gave above in regards to using a custom .css may give you the fine-point control over the UI of most apps... I can probably help you I.D. the classes you need to specify if you clearly define what Interface elements you wish to change. But the Browsers would be another story. They will (should) use the system Font... but to customize the individual elements within the interface, you would need to get into the webkit .css.

Some browsers, like Vivaldi, make this quite easy. Most do not. They are like Gnome... Their Browser Appearance is their recognizable Brand Image and they lock you out of customizing that.
With a lot of hassle, you can extract the .pak files and change the contents, then recompile... Only for the Next Update to undo all of your work.

1 Like