How do I configure the keyboard?

I noticed one key on my keyboard, when pressed shows something else and is where it's not meant to be.

X11 xkb is the utility that performs key mapping.
Let me see if I can find a good guide on keymapping. But in the meantime, can you describe the key in question and the symbols that appear - and whether they are misplaced - to figure out if this is a Bug rather than something that needs a setting change?

I press the symbol ~ and I get something that is not even listed on my keyboard but that looks similar to an horizontal L instead. It only plays up when in terminal, not in the browser.

I cannot remember offhand- are you using Zorin Core or Lite?
If Zorin Core:

If Zorin Lite:
Open the terminal, go to "Edit" on the menubar and select "Preferences".
Go to Appearance Tab, where it says "Use System Font" see if that is checked or unchecked. If unchecked, look and see what font it is using.

Type

locale

In a terminal window. This will show the system define language.

1 Like

locale spewed out list which indicates the correct country, the language is already correct and mentions UTF 8

GNOME Shell 3.18.5

The article appears to focus on fonts not how to tell the keyboard to change a symbol on the keyboard whilst in Terminal but thank you anyway.

I tied this suggestion from that link and I got

cat: /home/computer/.gconf/apps/gnome-terminal/profiles/Default/%gconf.xml: No such file or directory

I don't if I have Core or Lite but I don't see an Appearance Tab nor Use System Tab under any of the tabs

I know this.

The symbol in question is called tilde and its appearance is governed by the System Font. So, in checking the font, we can see why you are seeing the Wrong Symbol. If you are hitting the ~ key on your keyboard and some other symbol is showing - then we need to check the font, first, not assume that somehow, keys were swapped around which is less likely than a font issue.

One way you can quickly and easily test this is to Uncheck "use system font," then select another font from the drop down menu (e.g. Roboto) and see if the Tilde symbol (~) shows up normally.

Can you open terminal and click "Help" on the Menubar, then click "About".
That will tell us if it is Gnome-terminal or XFCE4-terminal being used.

A terminal emulator for the GNOME desktop
Using VTE version 0.42.5 +GNUTLS

So far, looking like Core.
To Follow JGordons suggestion above, even though you confirmed languages, it will not hurt to run this in terminal, just in case:

setxkbmap -layout us

To check gnome-terminal font:
From "Edit" on the menubar (Right click and check on Menubar if you do not see it), select preferences. A popup window will open.
Text Appearance should be first thing you see. There should be a checkbox for "Custom font".
Is it checked or unchecked?
Next to that is an Entry that has a Font Name on it- clciking it produces a drop down menu.
What font is currently being used?
If you click the Drop Down menu and change the font to say, "Ubuntu Mono" - then test the terminal, does the tilde (~) show up normally?

I'm not trying to sound simple, but are you using shift for tilde... the us keyboard does require shift for tilde. Otherwise you get the backtick. Depending on the font may look like a sideways L.

I assume he is getting this ¬ character, instead of tilde ~ character. On my US keyboad but UK language setup, both tilde ~ and ¬ are indeed swapped over, as are some other characters. But I'm used to that and have a cheat sheet.

1 Like

Interesting... I wonder if this is, indeed related. Is this only in terminal? Would you be willing to change the Terminal Font to test if that makes it change?

The same applies to those keys in both Text Editor and in Terminal. As I would expect.

I always knew that American English was different then British English, we use different slang, and say words differently, like the all famous word Aluminum.

And if you think about it, there is a good reason why, when after installing your OS, one of the first things the installer asks from you is, what keyboard language do you use?

So apparantly, all that matters in the end, and this is where the root issue and confusion lies.

Or... Check The Font Like I told You To!

OK Boss. :wink: Here is what I have got for Terminal Font.

So Font change to "Ubuntu Mono" does not affect those keys. But I am wondering if Encoding is abnormal e.g. foreign language ? There is a setting to select Default Compatibility, which I guess (not tried it) should set default Encoding.

1 Like

UTF 8 is normal- The reset to defaults May Help... I am not sure.

But Zabadabadoo, you solved it.
It is indeed the British layout.

Here is British /usr/share/X11/xkb/symbols/br
key { [ apostrophe, quotedbl, notsign, notsign ] };

That horizontal L symbol is the notsign or LogicalNot.

Here is US English /usr/share/X11/xkb/symbols/us
key { [ grave, asciitilde ] };

There is the Tilde sign.

So, the command I gave above should have worked.

setxkbmap -layout us

If not, checking @jgordon 's Locale suggestion may be the route.

localectl list-locales

I think this will work... Not sure If I wrote this right...

localectl set-locale en_US.UTF-8 LANGUAGE="en_US:en"