How do I disable built-in WiFi adapter so that I can use new USB adapter?

Subject is self-explanatory. I have an older laptop with a pretty slow internal WiFi adapter and I just purchased an external USB one that I would like to use instead. How do I go about that?

Keep in mind I don't want to disable the internal adapter via BIOS, but I'm certain there's a way to do this in Linux; I'm just very new to it. This is a multi-boot laptop and on Windows, all I had to do was open Device Manager, find the internal adapter, right-click and hit Disable. Done.

I found this link very helpful, wireless - How to disable built-in Wi-Fi and use only USB Wi-Fi card? - Ask Ubuntu

I also had to use the USB wifi dongle when i first started with Zorin, and even now i plug it in and select which wifi i want to use via settings, wifi and it connects like that. I didn't have an issue with double wifi

1 Like

Coincidentally, I did find that post when searching before posting here, but, like I said, I am pretty new to Linux (not just Zorin OS) and, first of all, I don't believe I have that interfaces file under /etc/network. I figured I could create it, but I also noticed the part that reads "Replace wlan0 with the interface you want to disable" and I don't even know how to determine that, so I gave up on that thread and decided to ask here.

What do you mean you select which WiFI you want to use via settings? I remember also checking the WiFi settings in Zorin OS and I don't recall seeing anything where you could select the hardware you want to use. I am logged into Windows on the same laptop right now, but I can double-check, confirm and post a screenshot later.

Thank you!

The /etc/network/interfaces file comes already present in Zorin OS.
To add the line needed quickly and easily, you can use Nano in the terminal:

sudo nano /etc/network/interfaces

You will use this command after determining your Wifi ID below...
Your file should be present, but empty. So whatever you add to it will then make it not empty...

First, let's make life easier and install net-tools

sudo apt install net-tools

Easy peasy. Now, let's use it to find the info you need:

netstat -ie

An ID beginning with en is going to be the ethernet. So, look for wl... It might be wlan0 or wlp5s0 or wlp3s0...
Use what you find there and:

sudo nano /etc/network/interfaces

Type in iface wl(Whatever-you-found-above) inet manual
Let's say it was wlp3s0:
iface wlp3s0 inet manual

Tap the ctrl+x key shortcut to exit, then tap the y key to say yes to save, then the enter key to save as current configuration and it will exit Nano.
The terminal will revert to normal.
Now enter in;

sudo service network-manager restart

And you should be done.

1 Like

OK. so first of all, THANKS A LOT! This worked like a charm and my card is now disabled, internet is gone. However, I don't know how to get the new one to work now. I assumed it would just work by plugging it in (I'm used to the Windows behavior), but no cigar. I also couldn't find any thing in the settings.

So the next thing I tried was going to the TP-Link site to see if Linux drivers are available, but I only find Windows and Mac drivers, here. The Amazon listing where I just bought this does say this adapter works just fine in Linux. You can see that in the answered questions here.

Can you please help me make this new device work on Zorin OS?

Thanks in advance!

UPDATE: I found this article, followed the instructions and I am up and running! Boy, are operations in Linux way less user-friendly or at least less for dummies than in Windows. I guess that's part of the charm for those who swear by it. I do wonder why there's no instructions on the TP-Link to do this. Any thoughts on that?

UPDATE 2: Turns out I am getting much, much slower download speeds (~13 Mbps) with the TP-Link adapter than I was with the internal one (~60 Mbps). However, I get much higher speeds with the same adapter on Windows (~160 Mbps). I certainly didn't expect this and I tested a few times in a row on both OS's. Any idea why? :face_with_raised_eyebrow:

Did you follow the Ubuntu Instructions?

It can be a matter of perspective, really. Above, we added one line to a file. Pretty easy stuff... Now, imagine a user like me trying to do the same which you described in GUI in your O.P. as quite easy.
But without knowing which button to push and where to navigate that Windows GUI, I would be utterly confused and lost and frustrated, yelling out, "Why can I not just adjust the file with One Line as I can in Linux? Why is Windows so user unfriendly?! ARGGHHH"
Perspectives matter - and familiarity matters. When it is familiar and you generally have a sense of direction, it is friendlier to navigate. When it is new and unfamiliar, it always seems unfriendly, no matter what the standard format it is using is.

Can you please detail the Exact device you are using? The instructions you linked show the rtl8812au driver to be installed. I wonder if you may need a different driver.
Also, if more than one rtl driver is loaded, it can cause very sliggish speeds. Can you please relay the terminal output of:

lsmod | grep rtl

1 Like

You're right about the familiarity bit. Everything that's familiar will be easier than anything that's not, regardless of the actual complexity. Now, imagine someone who's never seen a computer being given both a Windows and a Linux PC and asked to do a task. In Windows, at least there's a chance s/he'll find the option poking around for a while. In Linux, you need to know the exact commands, the exact files to add these commands to, etc. I am oversimplifying it, I know, but think of this very example. There's no way I could have found a way to do what I needed to do here unless I searched online or someone told me, like you (thank you again). In Windows, someone could see an application called "Device Manager" while looking at the list of installed apps (ships with the OS), opened it, noticed a device listed there called WiFi Adapter something or the other, clicked on it... nothing happened. Right-clicked on it and an option that reads "Disable device" would pop up. Bingo! Even if it took them 3 days to find it. It's just not possible in Linux for a task such as this one. It is not uncommon to find a reference to Linux being less for beginners and more complex to navigate through than Windows in any article that compares the OS's. This is what I mean. I fully digress from the matter at hand, but did want to add my 2c, since I am new to Linux, DO like it so far (especially Zorin OS and I've tried a few distros) and really value the opinions of the experts, of those who know it well, like you. :slightly_smiling_face:

Yes, I followed the Ubuntu instructions in that article.

You probably missed my link above, but here's the official driver download site for the actual device. It's a TP-Link Archer T2U Nano, purchased from this Amazon listing.

Here's the output of the lsmod command:

btrtl                  24576  1 btusb
bluetooth             651264  32 btrtl,btintel,btbcm,bnep,ath3k,btusb,rfcomm
r

Have I said thank you for your help? :wink:

This is true in Windows, as well. That is just the nature of an Operating System. And it makes sense when you think about it... There must be an exact path to a file, or neither Windows nor the User will be able to know where it is easily.
In Windows, there is much available in GUI settings. However, this is true in Linux, as well. Many users on the forum have noted that they never open terminal and use exact paths or exact commands.
I default to terminal often because it is good practice and precise... But mostly because it is just easier that way than in jumping through all the GUI steps and hoops.
I do not need to imagine... Since I was that person at one point in time. In fact, most of us were.
Most of us started out on Windows without ever using a computer before.
And I outlined the struggles in the post you replied to.

You can use the app HardInfo on Linux to the same effect - though I agree with your point that it does not ship with the Zorin OS Distro by default. Some distros do carry it by default.
So it is just as possible on Linux, exactly the same.
You just didn't know about the application. But do you know of every Windows application? (no.)
Google search on Windows problems and usage and issues... and you see all the same complaints as what you say applies to Linux, here. Sound not working. Net not working. Battery Life is poor...
Printer not being recognized...
And look at how they struggle to get help. If there isn't a GUI app handy with buttons to push - the user is totally lost.

No, I just did not have any confirmation that the device referenced in the article you linked to is Your Device. You might be surprised how often users post links to devices that are different from the one that they have. :wink:

Yes, lol. And given time, you may find yourself helping others with your experiences and troubleshooting as you see the need to fill.

Ok so...

This looks like it uses the rtl8812au driver which you referenced.
Generally, the easiest installation is

sudo apt install git dkms
git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au
sudo make dkms_install
chmod 777 rtl8812au

You mentioned that you already installed the driver. But your lsmod command doesn't show it...
Let's try using Inxi:

sudo apt install inxi

inxi -N

You should see an output like this:

inxi -N                                                                   ─╯
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi

Please relay that output here.

1 Like

Re: Linux vs. Windows... OK, OK, I hear you. I want to make it clear this is not a bash Linux type convo. On the contrary, I quite like it so far or I wouldn't be here asking how to configure it. :grinning_face_with_smiling_eyes:

Here you go:

Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  Device-3: TP-Link 802.11ac WLAN Adapter type: USB driver: rtl88XXau

Device 1 is my internal one. Should it even show if it's disabled? Device 3 is the dongle, which I know is working because it has a little LED that flashes whenever in use.

Thank you!

If Device 1 is your internal Wifi you disabled, let's blacklist the module driver:

sudo nano /etc/modprobe.d/blacklist.conf

Add this line to it:

blacklist ath9k

Tap ctrl+x, then y key, then enter key...
Restart and test...

1 Like

Same low speeds. :grimacing: And I did make sure the adapter was blacklisted after restart by re-issuing that inxi -N command. That Device-1 line now reads "none" instead of "ath9k". Also that it's using the dongle, since it blinks like crazy as the speed tests are conducted. It's still averaging around 10-15 Mbps. As mentioned, same dongle in Windows (different driver, of course) averages 10x those speeds.

1 Like

Let me look into this further (as I don't know either lol)...
It may well be that you are completely right and that Windows has a better Driver...
Maybe not, though.

1 Like

Thanks a lot. Really.

I just posted in the TP-Link forums, by the way. Here's my thread. Maybe I get an answer there.

1 Like

Can you check this Video guide here?

Might want to skip to start the video at 1:14 or so...

The short version is: He disabled Powersave... (which we often recommend doing on this forum, actually...)

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Change to:

[connection]
wifi.powersave = 2

Instead of 3.
Ctrl+x to exit, then the y, then the enter...
Restart and test.

1 Like

YES!!! That did it! 3 tests in a row averaged 130 Mbps downloads. Thanks a lot! Where can I go add you to a list of Linux heroes? :grinning_face_with_smiling_eyes:

1 Like

My Deviantart page, I guess.:stuck_out_tongue:

I've never really understood Devianart much, but I just created an account there, found yours and that's it, got stuck. No idea what I can even do. :laughing:

Not much lol. I do not understand it, either...
But until I (finally get around to) make my webpage, I am using it to promote my insanity.

Season 9 Lol GIF by The Office