How do I get a new HD to showup in "On This Computer" section in File Manager

Greetings All !
I just added a 3rd HD to my system and got it mounted etc, seems to be working.
Just wondering how to get it to show up with the rest of the drives under file manager - under "on this computer" is showing my 2 drives but not the 3rd new one.

Not showing up here -
Screenshot from 2021-09-30 00-18-54

but shows up on the side,

Screenshot from 2021-09-30 00-19-36

i have it mounted under the /media/

any comments are always appreciated,
Cheers !!

Hit the zorin logo. type disks, launch disks utility

Select drive on the left. On the right click on 3=dots.

Edit mount partition. Then click the toggle, you want it set to user selection.

Put checkmark in mount at startup. Before you close the DISKS utiltity, make sure the drive is indeed mounted, by making sure that if you see a PLAY symbol, click on it to mount the drive immedietly.

Restart computer if necessary.

2 Likes

Thank you so much for the response,
maybe its me, i may be missing it since im very tired at the moment lol -
but when i click the 3 dots i see the following
Screenshot from 2021-09-30 01-25-57

i clicked on the gears and in there i see the following
check under each menu for "edit", not sure where to find " set to user selection" as you mentioned.

1 Like

Sorry, even I forget sometimes. I helped another user with this exact same thing and I told him right, but I promptly forgot a week later, sorry.

Yes, from GEAR :gear: icon, EDIT MOUNT OPTIONS

2 Likes

i see ok , i was fumbling around myself lol - thanks..
ok so once in there , do you mean toggle/checkmark
"show in user interface" ?

1 Like

According to your screenshot, you already have things set correctly.

Restart the computer to help make sure things are finalized.

1 Like

restarted, still the same result unfortunately ,
I see the drive listed on the left bar, but dont see it under
"On This Computer"

OK, only other thing that I can think of, is you might now have proper ownership of the drive, which is easily solvable BTW. Open a terminal window...

CTRL ALT T

sudo nautilus

Type password.

Go to the drive in the file manager, you should find it under other locations. If not there, then were you mounted it then. Right click, go to properties.

Set the user and group to your account name on the computer. Set everything to create and delete files, you want complete access. Then at the bottom, change permissions for enclosed files.

Set everything to create and delete files, same way as the previous window. Now you should have full permissions of the drive.

2 Likes

Wait, 500GB volume, whats that? Isn't that the drive you want? Well its right there then if thats the drive you want to see on the left side of the file manager. You just got to click on 500GB volume to see it.

2 Likes

yes ! exactly , its been on the left bar since the get-go,
my question was how i can get it to show under "On This Computer" as shown in my screen shots :slight_smile:

You might be able to do that by using the method of bookmarks. I was just helping out another member here a few hours ago with that. The idea is, you click on the drive in file manager, go up to the name of the drive at the top, right click it, and add to bookmarks, like this.

1 Like

ahh ok i will revisit that, as i found a link for that earlier and tried it before posting on the forum. It didnt work but i will try it again.
:slight_smile:

Another thing you could do that I know is an option for sure. Is you can set the OS to display the removable drives on the desktop, which is very handy feature to have.

2 Likes

This is odd. It should show under Computer from Other locations by default.
And I can see it is mounted, by the eject symbol in your screenshot.

2 Likes

yes, i kept messing around with it, but to no avail. its not a big deal, but would be nice to grroup all your devices there ..
thanks for the input Folks, really appreciate it.

1 Like

Had you tried editing the entry into fstab?

2 Likes

yes i added the line in fstab so its mounted each time

/dev/sdc1 /media/GameDrive ext4 defaults 0 0