How do I install net Framework 4.8?

A Windows program [yWriter7.exe] will not install because .net framework 4.8 is missing. I use OS 16.3 Lite. Wine is current and works with other programs. Windows App Support and Mono both give the missing error message. The yWriter site [Spacejock] has tips for installing on Linux, and they didn't work, either. So, a usual plea for help with this. Thanks in advance.

  • Erik

Try this in a terminal:

$ sudo apt-get install winetricks


winetricks dotnet48

Absolutely no guarantees!


That's the one I usually suggest (edit: installed via wine) - I use 'wine uninstaller' in terminal, then 'Install', navigate to the installer, select, let it go, and then installed! :+1:

Dot NET is available in Ubuntu without need for Wine or Winetricks. I have it installed (and have for a long time). I highly recommend the APT version.
The Snap lacks functionality due to its container.


Installed it per your command line. Winetricks opens with a list of apps and no option to find another one. Running 'winetricks dothet48' resulted in a list of errors ending with -
'warning: This package (dotnet48) is broken in wine-6.0.3.'

What does 'natively' mean?

I found the Microsoft file ndp48-web [net framework].exe and tried to run it via Wine with no success. It hangs up. Also, will a later version of dot NET instead of 4.8 work?

Thanks for the definition of Natively.
I'm using Zorin 16.3.
I have been reading instructions in the search source you mentioned [by Linode]. It does not mention .net 4.8, however.

This online discussion may be useful for this specific case:

Simon at yWriter says to install net Framework 4.8. I have been unsuccessful doing that, thus my request for advice here.

It is wine 6.0.3.

In frustration I installed dot net 4.8 several times. Do I need to somehow remove them and do a fresh install?

I don't see messages from other people having these problems.

I just tried versions 5 and 7 both installable and standalone - are you getting an exception pop up when trying to open?

I found this, just fyi: WineHQ - yWriter

Looks like the latest version was around v6 for yWriter, Wine v3.. Likely not tested with the current versions offered of both (wine / yWriter), or didn't seem like it..

You could grab a Win VM image and use VirtualBox to run the software; if nothing else works. I haven't tried with POL or Bottles, not sure if either of those would help though.. You could use Wine Tricks to use Wine v3 to install V5 or V6 yWriter - but V6 shows 'Garbage' as the result..

If you look through your apps in wine uninstaller - does .Net4.8 show up? I don't remember having to do anything after installing, just running the app - but this app isn't tested beyond version 3.... so that may be a lot of the problems.. Mono and Gecko installed? I see in most of the notes that Mono is required to run.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.