How do i make the res stretched

i like to use 1024x768 but how do i make it streched no black bars?

This is not the option I would go for... It is far preferable to set your resolution ratio that is correct for your monitor.

Otherwise, you can try


and grab your output ID. It may be dp-1 or hdmi-1 or dp-0... Grab that and place it in the Placeholder in this command:

xrandr --output PLACEHOLDER --set "scaling mode" "Full aspect"

For example, if you are using HDMI-1: xrandr --output HDMI1 --set "scaling mode" "Full aspect"

1 Like

I was actually reluctant to answer this one because I seem to remember that Windows had this option in the display settings. But neither XFCE or Gnome have it, and when choosing a resolution with a pixel ratio that doesn't match you get the black stripes.

Although, I personally rather have these stripes if nothing else for the visual reminder that I'm messing with the settings.

Btw, doesxrandr work when using Wayland?

this code

xrandr --output HDMI-1 --set "scaling mode" "Full aspect"

gave me this error

X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 11 (RRQueryOutputProperty)
Serial number of failed request: 30
Current serial number in output stream: 30

I believe that this can be caused by the set resolution being a different resolution than the monitor default.
Is that the case? Or are you using the unchanged default resolution?

i dont think u understood what i want to do my laptop screen is not 1024x768 but i want to put it at that but i get black blars instead of streched res

Does this mean that you are using a non-default resolution currently?

Also, is your monitor connected via HDMI-1?

i dont use a monitor just the laptop screen and yes im using 1280x720

We need to move back up a couple posts and restart.

You need to grab your built in monitor connection I.D.

The HDMI-1 that you used was an example:

Please post the output of



If you are using a non-default resolution, we must make a change to a configuration file.
There are two important things to consider here.

You must use a refresh rate of 60hz if you are trying to use full aspect scaling. So if your preferred 1024x768 is set to 75hz, we need to change that.
And the other thing is that we must set your preferred 1024x768 as the default monitor res in xorg.conf.
For Example:

Section "Monitor"
    Identifier "HDMI1"
    Option "PreferredMode" "1024x768"

HDMI-1 is not the example i got that by running xrandr

If you are using a Notebook computer with Built in Monitor, how could it be HDMI?

Please post the output of


screen 0: minimum 320 x 200, current 1280 x 720, maximum 16384 x 16384
eDP-1 connected primary 1280x720+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
3200x1800 60.00 + 59.96 59.94 48.01
2880x1620 59.96 59.97
2560x1600 59.99 59.97
2560x1440 59.99 59.99 59.96 59.95
2048x1536 60.00
1920x1440 60.00
1856x1392 60.01
1792x1344 60.01
2048x1152 59.99 59.98 59.90 59.91
1920x1200 59.88 59.95
1920x1080 60.01 59.97 59.96 59.93
1600x1200 60.00
1680x1050 59.95 59.88
1600x1024 60.17
1400x1050 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 60.02
1440x900 59.89
1400x900 59.96 59.88
1280x960 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1360x768 59.80 59.96
1280x800 59.99 59.97 59.81 59.91
1152x864 60.00
1280x720 60.00 59.99 59.86* 59.74
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
960x540 59.96 59.99 59.63 59.82
800x600 60.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
800x512 60.17
700x525 59.98
800x450 59.95 59.82
640x512 60.02
720x450 59.89
700x450 59.96 59.88
640x480 60.00 59.94
720x405 59.51 58.99
684x384 59.88 59.85
680x384 59.80 59.96
640x400 59.88 59.98
576x432 60.06
640x360 59.86 59.83 59.84 59.32
512x384 60.00
512x288 60.00 59.92
480x270 59.63 59.82
400x300 60.32 56.34
432x243 59.92 59.57
320x240 60.05
360x202 59.51 59.13
320x180 59.84 59.32
HDMI-1 disconnected (normal left inverted right x axis y axis)

xrandr --output eDP-1 --set "scaling mode" "Full aspect"

The good news is that from that output, I can also see your refresh rate is set to 60hz. :slight_smile:

do i use while using 1024x768?

1 Like

Yes. Run that command when using the 1024x768 resolution.
If we are lucky... that is all that will be needed and your screen will be filled with no black bars on the side.
If not - we may need to change some configuration files.

no errors but i still have black bars

We were unlucky.

It is now 1am my time here, I will need to resume looking into this in the morning.

of course i understand thank you for helping

1 Like

Do you mean seeing everything truly stretched (like a special effect) or apply 1024×768 correctly to the screen without seeing black bars? Meanwhile, I found Custom Screen Resolution, Display (for Cinnamon desktop), Displays, and Monitor Settings (for RandR) on Software Center in case you're unable to achieve what you want. The workaround can be setting another resolution and then increase font, buttons and icons sizes, this will give you the feeling that you are using 1024×768.

Do you have a cinema screen :rofl:?

lol no just a laptop

1 Like