How do I restore Apper Icons

I installed Apper several times on my 16.3 Lite and removed and restored several times but no icons. Nothing major just an annoyance. Looks like this

Do You use a light Icon Theme? If Yes it couldn't be visible on the light Background of the Program.

Or You could try a sudo apt reinstall to reinstall Apper.

No I use a dark theme and reinstall doesn't make any difference.

1 Like

Hi banger,

Just installed Zorin 16.3 Lite as a VM and been playing with potential solutions but the last one that solved this based on an Arch forum thread was around xfce 4.8, we are now currently at 4.18! Apper is a KDE application that uses the Qt file system, also shared with LXQt, the descendent of LXDE. I installed both LXQt that had an issue with a Zorin setting which attempted to override Zorins xfcesettings file with a debian one, so removed that from marked installation which left the rest of LXQt available. Blank icons! LXDE - blank icons. I then installed:

sudo apt install kde-standard

and now they show:

So based on what I have found, some old statements claim it to be a bug, yet my personal feeling is that it is because it uses the Qt system, xfce does not. You can always use Synaptic Package Manager, or alternatively, use for applications.

Yes, exactly. Apper is written for Qt.

Users can apply GTK theming to their Qt apps should they prefer to not have to install a huge block of KDE dependencies:

1 Like

Tried both solutions. I should really do this in a VM first but neither worked. @Aravisian tutorial worked up until editing the two files in profile.d which didnt exist so I created them and added the line to the second one. I can change general theme but Icons dont show up.


You could try it with a Third-Party Icon Set if the Problem still exists.

Seeing this

Changing theme brings the icons up but when you open apper again they are blank and you need to change something in themes

And when You change the Icons?

And on Your ''Seeing this''-Screenshot is on the Warning Window shown that a Value is not right configured. But for this I don't know what You must do.

Changing Icons makes no difference just theme. in /etc/profile.d in /etc/profile.d

set to export QT_QPA_PLATFORMTHEME=qt5ct

Yes @Aravisian I did this as elevated. The files didn't exist in profile.d so I created them. Got the error.

Are you on Zorin OS 16 or 17?

He's on 16.3 Lite - in the OP. The only way i could get it was installing KDE standard (just removed kde-standard in terminal but still a lot of KDE (Plasma) present. If I open Settings in Zorin 16.3 Lite there is KDE System Settings. I did install elementary Xfce icon theme earlier without success, but using KDE System Settings | Appearance | Icons I can get them to show:

I have given up and will use Synaptics, have timeshifted back to the other day before the KDE changes and Tutorial as somethings werent working and extra KDE stuff was taking ages to open. Will have a play on a VM of 16.

This is odd... Those files are included by default in Zorin OS.

In fact, I have even notified the ZorinGroup that they made an error in setting up the default file by setting the default as gtk2.

I just checked my Zorin 16 and 17 VMs and the files aren't there. 16 was a fresh install so something has changed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.