How i can add sensor cpu temperature to conky manager?

I have installed conky manager , it's good , but i can't find cpu temperature widget in it. how i can add it to conky manager?

I use a homemade conky for temps... but you can also search the web for one. DeviantArt or Pling may yield what you would like.
You can also add temp sensor to your rc conky, which I also do. This allows me to quickly check temps from pretty much anywhere... others seem to monitor temps a lot less than I do...
Temps are often read in conky by calling on hwmon.
To get your conky to give you the Right Temps, you may need to check your hwmon tree to see which you need to call.
For example, calling hwmon1 or hwmon0.
Once you have your preferred conky script, we can tweak it as needed.

1 Like

thanks , i found a lot of widgets in pling these have weather and temp , but it can't display the value of weather or temp or network:

In some regards, doesn't the systen build require hardware sensors to be present? For example, m'lady's iCute case came with a heat sensor.

1 Like

I have solved value of weather, it's required to pass city id to parram.
but for cpu temp, i can find it, i tried to run that command to show what i get in terminal
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~$ sensors
k10temp-pci-00c3
Adapter: PCI adapter
temp1: +41.8°C (high = +70.0°C)

A conky must pull this information from somewhere.
This is why:

The conky file should be located in ~/.conky - once you locate it, can you post its content in this thread?
You can use the </> tags shown in the toolbar.

conky.config = {
--==============================================================================

--  Created : 2022/Sep/02
--  This theme is for conky version 1.10.8 or newer
-- 
--  ARRAKIS
--  ( A part of Draco Conky themes pack )
--
--  author  : Closebox73
--  license : Distributed under the terms of GPLv3
--  notes   : Created on 1366x768 Monitor

--==============================================================================

-- Size and Position settings --
  alignment = 'top_left',
  gap_x = 20,
  gap_y = 0,
  maximum_width = 220,
  minimum_height = 700,
  minimum_width = 220,
  
-- Text settings --
  use_xft = true,
  font = 'Dosis:light:size=9',
  
-- Color Settings --
  default_color = '#F9F9F9',
  default_outline_color = 'white',
  default_shade_color = 'white',
  color1 = '#E85B18',
  color2 = 'FF1493',
  
-- Window Settings --
  background = false,
  border_width = 1,
  draw_borders = false,
  draw_graph_borders = true,
  draw_outline = false,
  draw_shades = false,
  own_window = true,
  own_window_colour = '000000',
  own_window_class = 'Conky',
  own_window_argb_visual = false,
  own_window_type = 'desktop',
  own_window_transparent = true,
  own_window_hints = 'undecorated,below,sticky,skip_taskbar,skip_pager',
  stippled_borders = 0,
  
-- Others --
  cpu_avg_samples = 2,
  net_avg_samples = 2,
  double_buffer = true,
  out_to_console = false,
  out_to_stderr = false,
  extra_newline = false,
  update_Dosisval = 1,
  uppercase = false,
  use_spacer = 'none',
  show_graph_scale = false,
  show_graph_range = false,
}

conky.text = [[
${execi 300 ~/.config/conky/Arrakis/scripts/weather.sh}\
${alignc}${voffset 0}${font Dosis:bold:size=12}[ ${color1}WELCOME ${color}${execi 6000 whoami | sed -e 's/\(.*\)/\U\1/'} ]
${alignr}${voffset 20}${font feather:size=40}${execi 15 ~/.config/conky/Arrakis/scripts/weather-text-icon}${font}
${offset 0}${voffset -80}${font Dosis:bold:size=70}${time %H}${goto 120}${font Dosis:bold:size=11}${time %^p}${font}
${offset 0}${voffset -15}${font Dosis:bold:size=70}${time %M}${font}
${offset 115}${voffset -50}${color1}${font Dosis:bold:size=15}${time %B}${font}
${offset 115}${voffset 0}${font Dosis:size=15}${time %A}
${offset 0}${voffset 15}${color}${font Dosis:size=10}The Weather in ${execi 100 cat ~/.cache/weather.json | jq -r '.name'} is ${execi 100 cat ~/.cache/weather.json | jq -r '.weather[0].main'}. ${execi 100 cat ~/.cache/weather.json | jq '.main.temp' | awk '{print int($1+0.5)}'} °C
${offset 0}${voffset 0}${color}${font Dosis:size=10}Wind speed in your location is ${execi 100 (cat ~/.cache/weather.json | jq '.wind.speed')}m/s
${offset 0}${voffset 0}${color}${font Dosis:size=10}And Humidity is ${execi 100 (cat ~/.cache/weather.json | jq '.main.humidity')}%${font}
${alignc}${voffset -5}${font Dosis:size=23}--------------------------${font}
${offset 0}${voffset 0}${font Dosis:bold:size=12}Wi-Fi : ${execi 5 ~/.config/conky/Arrakis/scripts/ssid}
${offset 0}${voffset 2}${font Dosis:size=9}Down : ${downspeed wlp9s0}${goto 120}Up : ${upspeed wlp9s0}
${offset 0}${voffset 0}${color1}${downspeedgraph wlp9s0 30,105}${alignr}${upspeedgraph wlp9s0 30,105}
${alignc}${voffset -15}${color}${font Dosis:size=23}--------------------------${font}
${offset 0}${voffset 0}${color}${font Dosis:bold:size=12}System info
${offset 0}${voffset 3}${color}${font Dosis:size=10}Cpu ${goto 40}>> ${cpu cpu0}%${alignr}${color1}${cpubar cpu0 13,140}
${offset 0}${voffset 0}${color}${font Dosis:size=10}Ram ${goto 40}>> ${memperc}%${alignr}${color1}${membar 13,140}
${offset 0}${voffset 0}${color}${font Dosis:size=10}Temp ${goto 40}>> ${acpitemp}°C${alignr}OS >> ${distribution}
${offset 0}${voffset 0}${color}${font Dosis:size=10}User ${goto 40}>> ${execi 6000 whoami | sed "s|\<.|\U&|g"}${alignr}BAT >> ${battery_percent}%
${alignc}${voffset -10}${color}${font Dosis:size=23}--------------------------${font}
${offset 0}${voffset 0}${color}${font Dosis:bold:size=12}Storage
${offset 0}${voffset 0}${color}${font Dosis:size=10}System :${goto 120}Home :
${offset 0}${voffset 3}${color1}${fs_bar 13,105}${alignr}${fs_bar 13,105 /home} 
${offset 0}${voffset -5}${color}${font Dosis:italic:size=8}${fs_used} / ${fs_size}${goto 120}${fs_used /home} / ${fs_size /home}
${offset 0}${voffset 10}${color}${font Dosis:bold:size=12}Music
${color1}${offset 0}${voffset 1}${font Dosis:bold:size=11}${mpd_artist}${font}
${color}${offset 0}${voffset 0}${font Dosis:italic:size=9}${mpd_title}${font}
${color}${offset 0}${voffset 3}${font Dosis:size=8}${mpd_elapsed}${goto 40}${color1}${mpd_bar}${font}
]]

I have solved weather by go to weather script and insert value instead of params
but for temp of pc , i can't find any script for it.
and i don't know why network values doesn't work

For your Network
Search this line in your Conky Script:

${offset 0}${voffset 2}${font Dosis:size=9}Down : ${downspeed wlp9s0}${goto 120}Up : ${upspeed wlp9s0}

Notice that it is identifying the wifi as wlp9s0. This is likely that you are not using wlp9s0 as your net ID and that was the ID for the original conky creator. You need to change this to your wifi ID.
To find your Wifi ID, open terminal and run:

ifconfig

Your Ethernet will be at the top, and wifi at the bottom. It will start with a w, as well. Copy that ID.
For example, mine is wlp5s0
In the open text editor for your conky script, you can use the Find And Replace Feature.
Search wlp9s0 and then paste in Your actual wifi ID in the proper field and select "Replace All"

For CPU Temp
Search this line

${offset 0}${voffset 0}${color}${font Dosis:size=10}Temp ${goto 40}>> ${acpitemp}°C${alignr}OS >> ${distribution}

You want to focus only On this: ${acpitemp}°C and change it to ${hwmon 1 temp 1}°C

Save the conky file and test.

1 Like

thank u, network worked very good with me, but temp not worked

What is the terminal output of:

ls /sys/class/hwmon/hwmon1/

eid@eid-HP-Compaq-6005-Pro-SFF-PC:~$ ls /sys/class/hwmon/hwmon1/
ls: cannot access '/sys/class/hwmon/hwmon1/': No such file or directory

Can you please run

sudo apt install lm-sensors

i have already installed it

You may need to install the lm-sensors package. After this run the following command and answer the questions. I was advised to answer yes to all questions and reboot. sudo sensors-detect

1 Like

good , after reboot, i run that command sensors and get that result in terminal:
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~$ sensors
smsc47b397-isa-0880
Adapter: ISA adapter
fan1: 1864 RPM
fan2: 0 RPM
fan3: 0 RPM
fan4: 1713 RPM
temp1: +42.0°C
temp2: +74.0°C
temp3: +35.0°C
temp4: -128.0°C

k10temp-pci-00c3
Adapter: PCI adapter
temp1: +42.0°C (high = +70.0°C)


what i can do next?

that is the result of ls /sys/class/hwmon/hwmon1
eid@eid-HP-Compaq-6005-Pro-SFF-PC:~$ ls /sys/class/hwmon/hwmon1
device name power subsystem temp1_input temp1_max uevent

Is this what you are looking for?

1 Like

Good, that is now reading after @Winged1 's suggestion of sudo sensors-detect

Can you please refresh the conky and test?

1 Like

Thank u very much , it's working very good now