How i can install glib2.0>= 2.66 in zorin lite(xfce)?

there r apps need glib>=2.66 version to install it. i have searched for ways to get glib 2.66, but the xfce community administrator told me that:
Zorin 16 is based on ubuntu 20.04 which uses glib 2.64. Ubuntu 21.10 has glib 2.68 and 22.04 has glib 2.72.

No, You cannot. You need to install a distribution running 22.04 cause Zorin runs on 20.04 and Cannot Support 22.04 apps just like you cannot upgrade Zorin to 22.04 or you should wait until Zorin 17 is released.

1 Like

Actually... most any package you are seeking to install should have a supported version. It looks more like you are trying to install later versions, rather than using the ones formatted for your system.
It might be helpful if you list the apps that you are trying to install and we can help you find the proper version.

1 Like

I was trying to install the last version of xfce panel

https://forum.xfce.org/viewtopic.php?id=15918

[Please note that this is a development release.]

3 Likes

Yes... ummm... Aside from a few minor bug fixes and two api corrections, the 4.17 and 4.16 xfce-panels are pretty much identical. It is not worth it to you to try to install it.

2 Likes