How I can make launcher for that type of application

image
There are some application to run it , I should do what in the picture, how I can type these commands in the command proprity in a launcher? I tried that but not worked:sudo ./VentoyGUI.x86_64/Downloads/ventoy-1.0.73

In the menu editor, make a new entry and add this command.

sh -c "cd /home/eid/Downloads/ventoy-1.0.73 && ./ventoyGUI.x86_64"
1 Like

I tried that but it is not working, I don't know maybe the first command work, but the second command not

Make sure that the script/bin is executable.

1 Like

I create a file like this on my desktop, or copy to /usr/share/applications to get it to show up in the menus (categories).

[Desktop Entry]
Version=1.0
Name=PiQ Data Logger
Exec=python3 /home/james/Projects/Python/raspberryPi/PiQDataLogger/PiQDataLogger
Icon=/home/james/Projects/Python/raspberryPi/PiQDataLogger/images/PiQDataLogger.png
Type=Application
Comment=A Python script to monitor data from the Sense Hat
Categories=Monitor;Development;Education;Science;Utilities;

Search the web for the options and what you need to set them too.

1 Like

have you tried to set it as executable?

chmod +x ventoyGUI.x86_64

and then run it.

I don't know why that kind of these applications must run with ./ before it?
I found that in its instructions about the app:
"If it can not startup after double-click, you can open the terminal and just execute the file (e.g. ./VentoyGUI.x86_64)". why VentoyGUI.x86_64 without ./ doesn't work?
what I did is that moving the content of the folder of the app to home, and make a launcher with the command ./VentoyGUI.x86_64. it's good, but it makes home folder messy

Bash uses the variable $PATH to find executables/scripts to run.

The ./ is the current directory, which isn't in the path, and is a relative path.

You could use the full path

/home/eid/Downloads/ventoy-1.0.73/ventoyGUI.x86_64

1 Like

that should work, but in the instruction of the app in the readme, they talked about that expected that will not work, that screenshot from the readme file of the app:

This starts a web service, which usually automatically opens a web page in order to configure Ventoy (its an html front end). The "app" will not show a seperate window. Try reading https://linoxide.com/how-to-install-ventoy-on-ubuntu/ and using http://127.0.0.1:24680 in your browser to access the Ventoy "page".

1 Like

it's solved ,it's my fault ,I was typing the command or the exec only and ignoring typing the path of the field of working directory (path) to the launcher. Thanks for all

1 Like

Can you post your file for others to see?
Always nicer seeing an example of what actually works.

creating launcher at task menu
ff

desktop launcher
yy