How to add steam games to desktop

Thanks to all for the help, I will be factory resetting my OS next month and restart because my internet is currently capped due to reaching my FUP, but thanks to everyone.

Don't forget to back up your important data BTW.

Zen .... I think you may be right as I just checked my Flatpak list and Steam is not on it ..... I have icons for games on my desktop and in my Main Menu Game list as Aravisian stated .....

1 Like

I think it's worth a short to just check it if only to confirm that's the cause of the issue, as more people will likely experience the same.

1 Like

I use an external drive for my games. Before i downloaded anything, i went into steam, settings (upper left corner) and clicked the downloads button. There, i hit the plus and created a stream directory where I wanted it. While it was highlighted, i clicked the three vertical dots under the directory graphic, and choose make default.

You can do the same, then move the games to the games directory. They live at one of the following:


This may require steam to run as root.

To avoid root, you can change the permissions on those directories, or create a games directory under .local in home.

1 Like

He was banned because he used linux and they don't know if you cheating.

1 Like

Very interesting video ...... have I ever used "Trainers" in the past to play games you bet'ch but never online as I never until I switched to Zorin .... and never with multiplayer games ..... I will usually play a game through once and then use a "Trainer" to replay the game for fun ..... but now that I use Steam to play games for Linux I don't bother ..... :sunglasses: :grinning: