[HOW TO] Better Touchpad Gestures on ZorinOS

Hey all! I found the ZorinOS default gestures quite lacking but fortunately, ZorinOS comes with TouchEgg pre-installed so it's pretty easy to customize the gestures.
However, an extension that comes pre-installed conflicts with TouchEgg so it also is a hurdle.

I have created an intuitive guide to have better (imho) and more feature-rich touchpad gestures on ZorinOS.

GUIDE

Installation

Since ZorinOS 16 already comes with TouchEgg preinstalled, you don't install TouchEgg manually :slight_smile:

Just copy and paste the line below in your terminal.

gnome-extensions disable x11gestures@joseexposito.github.io; rm -f ~/.config/touchegg/touchegg.conf; git clone https://github.com/NayamAmarshe/ZorinGestures.git; cd ZorinGestures/; cp touch* ~/.config/touchegg/;

That's it!

Usage

Swipe Gestures:

  • 3 Fingers UP or DOWN: Switch Workspace
  • 3 Fingers LEFT or RIGHT: Change Volume
  • 4 Fingers UP or DOWN: Show overview
  • 4 Fingers LEFT or RIGHT: Go Back and Forward

    [BROWSER ONLY]

Pinch Gestures:

  • 3 Fingers PINCH IN/OUT: Maximize and Restore Window size
5 Likes

Nice tutorial! Thanks for it! It will definitely improve my workflow

1 Like

I have updated the guide, please take a look at the GitHub link as I'm unable to edit the post.

Hi, this looks really awesome.. I have enabled horizontal workspace. Is it possible to switch the 3 finger left or right to switch workspaces and 3 finger up and down to show overview?

Yes of course, You can use the app 'touche' to customize the gestures after installing my config files.

Hello @NayamAmarshe! I trully loved your tutorial and the new gestures, especially the one for volume levels are amazing, but something bothers me.
I use a laptop, since I don't have a desktop PC, but I often use an external keyboard and mouse. If I'm using the external keyboard and, for some reason, use the laptop keyboard, the screen freezes for a few seconds. It's like the system freezes to recognize the new keyboard. The same happens with the gestures: when I use the 3 finger horizontal swype to adjust the sound level, the screen freezes and then gets back, if I use the keyboard, then the screen freezes one more time.
I have absolutely no idea what this can be, if you know, your help would be much appreciated.

@glhrmlz Make sure 'Disable While Typing' option is disabled in Touchpad settings.

image

1 Like

As soon as I get near my computer, I'll try it. I'll reply this message when I do. Thank you

Ok, I did it. Yet the problem with the screen freezing persists

This is not an issue related to Touchegg I believe.
Still, you can take a look here: How to fix USB mouse and keyboard freezing? - Ask Ubuntu

how to uninstall this ?

I just updated the instructions for uninstallation but it won't work for those who already have installed my config.

To revert,
You'll need the original touchegg config for ZorinOS. This original file can be found in ~/.config/touchegg folder and it's the file named touchegg.conf.
You can obtain this file by booting a ZorinOS live USB or booting ZorinOS in virtualbox.

After copy-pasting the original file, just enter this command in the terminal:
gnome-extensions enable x11gestures@joseexposito.github.io

Sorry for the trouble, but since I've updated the instructions, any future installations for my config will be 100% revertable.

1 Like

This one is just GOLD..!!
Thanks

2 Likes