How to change the default display by the terminal? [Solved]

Recently, I watched some content with the laptop connected to television via HDMI cable. Everything worked correctly, without any complications.

However, today when you turn on the device, the LED lights came on, but the screen didn't. In fact, the screen is black, but with no image at all. After some tests, I decided to connect the laptop to the TV and the Zorin OS 16 Core charging screen appeared.

But, the login screen does not appear complete and, due to this, I cannot enter the password to access the system. I imagine that if I have access to the system, I can switch the image from the TV to the laptop display, but I don't know how to do it via terminal.

Does anyone have any suggestions? :thinking:

1 Like

Use: command line - How can I list connected monitor(s) with xrandr? - Ask Ubuntu to list active monitors
Then use: 14.04 - How to set primary monitor and relation between monitors on ubuntu using terminal? - Ask Ubuntu to switch

1 Like

I have typed:

xrandr

Then that message appeared:

Can’t open display

I think I read somewhere you are best booting the Notebook first then connect your TV and use the Fn+ F# keys to change display output to external monitor.

1 Like

Try the suggestions here: Cant open display : xrandr --output HDMI-0 - Linux Discussions - Engineering and Component Solution Forum - TechForum │ Digi-Key

1 Like

Hey, @swarfendor437

Unfortunately, I tried to do this a few times. When I press Fn + F5, Fn + F6 and Fn + F7, I can decrease the brightness, increase the brightness and turn off the laptop screen.

However, precisely the function to switch between the TV and the laptop screen (Fn + F8) does not work. I think it may have to do with the monitor resolution, but I'm not sure. :neutral_face:

Thanks,

Jônatas Rocha.

Hi, @carmar

Just to confirm if we are talking about the same terminal, I am accessing this terminal by pressing Ctrl + Alt + F2 on the login screen. I will try to apply what was recommended in the topic you sent in this terminal, okay?

In case I can't, do you know any way for me to eliminate the need to log in by typing the password? I believe that if I can access the system directly, I can solve the problem through the system settings. :neutral_face:

Regards,

Jônatas Rocha.

Try gnome-terminal --full-screen
If that doesn’t work, try gnome-terminal --geometry=100x100 and play with those dimensions.

1 Like

I can’t access that terminal.

If on Zorin OS Lite, replace the word 'gnome' with 'xfce4'
So, enter in alt+F2: xfce4-terminal --full-screen