How to completely disable Zorin OS 16.3 Lite [XFCE] Screensaver

In order to completely disable Zorin OS 16.3 Lite [XFCE] Screensaver function or to simply prevent your computer from suspend, you can follow the steps below:

  1. Access the 'Settings Manager' app, and click on 'Screensaver'.

  2. Disable the 'Enable Screensaver' option. If you want, you can also go to the 'Lock Screen' tab and disable the 'Enable Lock Screen' option.

  3. Return to the 'Settings Manager' main menu by clicking the 'All Settings' button.

  4. Click on 'Power Manager', and navigate to the 'System' tab. Within 'System power saving', in the 'When inactive for' option, drag the little ball completely to the left side of the screen, until the message below appears "Never".

  5. Still within the 'Power Manager', navigate to the 'Display' tab. Disable the 'Display power management' option. Make sure that the 'On inactivity reduce to' option is set to "100%". And the 'Reduce after' option is set to "Never".

  6. Close the 'Settings Manager' window.

  7. Search your system for the 'Session and Startup' program, and navigate to the 'Application Autostart' tab.

  8. Within the 'Application Autostart' tab, uncheck the 'Screensaver' program option. Close the window.

  9. Restart your computer and run your tests to check the results.

By following all these steps, your computer will no longer fall asleep, much less enter Screensaver mode. :upside_down_face:

NOTE: If you clean your system using, for example, BleachBit, it is likely that you will have to repeat steps 7, 8 and 9.

Hope this helps!

P.S.: If anyone knows how to automate all of this using a script, please post here. :sweat_smile:

:blush: :handshake:

4 Likes

This works:

gsettings set org.gnome.desktop.session idle-delay 0