How to Cure Lagging in a Game

I have never experienced this in a game before .... never ..... in fact I didn't even know what it was until I tried researching it ...... it is like I'm a zombie I can't run and my footsteps in walking mode sounds like I'm Frankenstein walking and about as fast ..... I'm running NVIDIA .....

Here are my laptop video card specs ....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo lshw -c video
[sudo] password for mike:
description: VGA compatible controller
product: TU117M [GeForce GTX 1650 Mobile / Max-Q]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:150 memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4000000-a407ffff
description: VGA compatible controller
product: UHD Graphics 630 (Mobile)
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:141 memory:a2000000-a2ffffff memory:80000000-8fffffff ioport:5000(size=64) memory:c0000-dffff

And also laptop spec's sorry it is when I used Windows 10 as I don't have a program to show my hardware now .....

Finally here are the game spec's for my set-up according to game itself ..... I changed the FOV from 60 to80 as described by one gamer and it did help some but didn't help me run a marathon but it was a bit better .....

Sorry forgot to tell the name of the game ...... DUH ...... it's theHunter Call Of The Wild ...... sorry .....

Have you tried switching to Proton Experimental?
Have you tried launching without OpenGL?
Is Nvidia set to On Demand?

1 Like

Yes .... I've tied all Proton versions from Experimental to 5.0.3 and none will launch the game except 6.3.8

What and where is this ???? .....

Not sure where do I find this out ????? .....

If the game support Vulkan you could try with

1 Like

I tried both of your recommendations and they seemed to help some but we still have some problems ..... I went into the video settings and tried out different ones and seemed to make some more progress ..... I turned Anti-Aliasing completely off as I think I remembered that that could cause Lagging .... that helped some ....

Then I put most of the other settings on Low and now I can walk fast in the run mode so that made a big difference but of course the quality sucks .......

Surely my laptop is with in the specs for this game to run .... I even tried the Generic X Org X server Driver just for kicks and that didn't work ....

I'm now using NVIDIA driver metapackage from nvidia-driver-470 (proprietary) ..... I know there is 525 and 535 but not sure about those ....

Thanks for your help .... anyone got any other ideas ????? ....

I'm running the game video like this right now .....

It is currently set to 'On Demand'

you have to log in X11 instead of wayland. This could also explain you low FPS. Wayland on Zorin is not up to date, so it's not wise to use.

Sorry it took so long to get back to you ..... in Performance Mode the game would not launch ..... so I went back to the previous setting and it launched but same problem as before ....... could this mean that the game is launching in Intel instead of NVIDIA ?????? ..... just curious .....

I would like to add that the lagging only occurs with the movement of my character such as walking or running ....

Raising weapons ..... looking through the rifle scope ..... turning etc. appear to work just fine ......

If no one has any more answers I can play the game and I bought the ATV for $5.00 using a DLC so I can get around faster now to places I want to hunt ..... I just use a fast walk for run and a very slow walk for walk ..... I guess after all I never used to run while stalking game in real life .....

Before someone makes a comment about me shooting poor little Bambi ..... I don't shoot Bambi but his Father & Mother are fair game ..... :sunglasses: :rofl: :rofl: :rofl:

Haven't figured out what I'm going to do when a bear or moose chases me ..... guess we'll just have to see that when it happens ..... but there again in real live you can't outrun those critters anyway ..... :rofl:

1 Like

I just found this one-line ..... does anyone know if this will work using Steam with Proton ..... before I try it and screw things up ..... :crazy_face:

Low FPS / poor performance / lagging on PC

If you have low FPS and it seems that the game is using he integrated GPU over the dedicated one, try the following:

  1. Quit the game
  2. Go to Avalanche Studios\theHunter Call of the Wild\Saves\settings<steam_id>\settings.json
  3. Open settings.json - any text editor, like WordPad or Notepad will work just fine
  4. Find "DisplayDxAdapter": -1, line
  5. Change the value to 1
  6. Save the file
  7. Start the game again

If changing this to 1 does not help, try changing it to 0 instead.
Make sure to not delete the comma "," at the end of the line you're editing.

Also please make sure your graphics drivers are up to date (if they are you might try re-installing them just to make sure nothing went wrong during last installation).

I just found this and it allows me to play everything on medium ...... gamemoderun %command% ..... I replaced ..... -force-glcore .... with the one above ....

Should I run both of these in launch parameters ????? .....

Huston we have a lift off ..... I left the combo in launch also turned off the Anti-Alising and everything is back on high ..... I can live with this .....

Thank you to everyone who contributed to this thread and those that followed along ..... it was a battle .... :exploding_head:

Not sure to who gets the 'Solution' as so many people contributed to solving this problem ..... but for now we can put this to rest unless something else rears it's ugly head .... but that's a post for another day ..... :+1: :smile:

I'm off to play theHunter Call of the Wild ..... :clap: :clap: :clap:

Well that didn't last long I jumped the gun a little to soon ..... it isn't solved .... what appeared to work just made it slightly better than before but not as it should be .....

I just changed NVIDIA driver to (open kernel) metapackage from nvidia-driver-535-open (proprietary) ..... it didn't help ... ... why did I choose that one ???? ..... I have no idea I'm just grasping at straws right now .....

I can only play the game a 1/2 hour at a time before I get to frustrated to continue .....

I checked the game spec's and I am defiantly with in the preferred range ......

Gonna take a nap my head hurts ......

One quick note Steam will not allow me to log into vulkan any more ..... the screen pops up but then before I can choose it disappears but it does that on other games on Steam also ....

I don't believe it ..... the game is now running butter smooth thanks to a post on ..... this is kinda what I had suspected today after I tried to run NVIDIA in 'Performance' again and in 'Intel' ..... it changed to 'Performance' but the game wouldn't run and it wouldn't even open in 'Intel' .... wouldn't except the check mark in the box .....

Tinker Steps:Set launch options

VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json %command%


set the mousepolling rate to 500 for smooth movement

► Multiplayer

Overall (online):Excellent

if you use a laptop with hybrid graphics like me(intel nvidia) you need to use this command to force the game to run over the nvidia gpu, otherwise you only run with 1 fps.

If someone with the ability to do so remove my 'Solution' above and put it on this post ..... thanks

If I could also add ..... I went back to NVIDIA 470 .... I also noticed my laptop started much quicker along with other desirable improvements ..... :+1:

Sure thing.

1 Like

Thank you kind sir ..... that was a long hard ordeal but this game is a super lot of fun now ..... I played it for about 3-4 hours ....

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.