How to disable auto-brightness

How do I disable auto-brightness? It keeps changing randomly at odd intervals. I am using MSI GE72-2QD laptop.

I've executed the following commands but nothing has changed.

gsettings set org.gnome.settings-daemon.plugins.power ambient-enabled false
gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

Any help would be highly appreciated.

1 Like

The commands you entered should work. I wonder if perhaps AutoBrightness is not the thing you are looking for.
Zorin OS comes with another feature that changes the tone of the desktop vs. night / day.
Can you please clarify what it is that you are seeing and wish to change?

You may check in Zorin Appearance for something like "Night mode".
Or Zorin-Appearance > theme > Background - the middle button that has a Sun / Moon icon.

2 Likes

Have you tried disabling it from the GUI Switch? You can find the option in

Settings -> Power -> Auto Adjust brightness

2 Likes

Fixed it on mine, Thank you

2 Likes

Maybe disable screen dimming?

2 Likes

how to enable auto-brightness/dynamic brightness for additional monitors? I've looked in the settings can't find it.