How to disable Bluetooth from turning on automatically on start up?

Hello, every time I start up I see bluetooth is automatically turned on. How do I disable that so that it is turned off by default?

Using 17.1

You go in the Settings and there to the Bluetooth Tab (should be 3rd from above). And there You turn off the Switch in the upper right Corner. Look at the red Mark here:

1 Like

but does that turn it off from automatically being enabled on start up or just for that session?

It permanently disable it. Try it. Turn it off, make a Reboot and then control it.

This forum exists as a helpful environment where users can achieve direct one-on-one help with issues.
If we can just "Google" up solutions, the forum would have no need to exist, nor would nuanced or individualized answers be needed.
Importantly, the only reason that Google can supply any answers at all is from those who asked others and received answers from others. Google did not make the answers. It retrieved them.

This is not an appropriate response to user inquiries at any time.

4 Likes

I did try that and it defaults to being turned back on....

So, You turned off the Switch, started the System new and the Switch was on?

correct

And the Switch in the Quick Settings? Is this active?

yes, active. I have tried disabling both but they always revert upon restart.

Do you use any Bluetooth Devices? Mouse, Keyboard, Headset, Speaker anything?

You could try to disable Bluetooth in the Terminal. For this type in the Terminal:

sudo systemctl disable bluetooth.service

3 Likes

As @Ponce-De-Leon suggests, sudo systemctl disable bluetooth and sudo systemctl enable bluetooth should survive a reboot.

If those terminal commands are not surviving reboot, please note that.

2 Likes

One last Idea I still have but I will wait if this will solve the Problem.

this has worked.

2 Likes

alternatively ...settings - session and start up - application auto start - untick blueman applet

cant see a "session and start up" option in settings?

That is Zorin Lite. @Newzoringuy uses Core.

ooh ok ,see that now ...my bad