How to disable Bluetooth from turning on automatically on start up?

sigh....now I can't turn bluetooth on.... any ideas?

When You used the disable Command, now You have to enable it. Open the Terminal and type:

sudo systemctl enable bluetooth.service

how do i make it so that this works via the taskbar button again but does not enable bluetooth by default on start up?

Normally it should work like this by default. The bluetooth.service is enabled and then You can turn it on and off with the Button in the Quick Settings or in the Gnome Settings like I showed You You the Screenshot at Post #2.

We could try 2 Things:

  1. Enable the bluetooth.service with the Command that I wrote. Then test again if it works or not. If it shouldn't work, test it if it is a Wayland/Xorg Issue. To test that, go to the Login Screen and click on Your Profile so that the Password Field appears. It must appeared! Then You see in the bottom right Corner a Gear Icon. Click on it and change there between the Modes and test if the Bluetooth work better. You should have there the Option Zorin Desktop (that is Wayland) and Zorin Desktop on Xorg. What is active You can see on the Point Marker.

  2. We change something in the main.conf File from Bluetooth Configuration. To do that, open the Terminal and type sudo nano /etc/bluetooth/main.conf and then You navigate with the Arrow Keys alle the Way down to the End. There You should find this:

Look what You have there. I mean if there stand AutoEnable=true. If Yes, change it to AutoEnable=false push ctrl+o to save the Change, Enter to confirm and ctrl+x to close. After that reboot Your Machine and try if the Bluetooth works like You want.