How to disable media keys?

I just installed zorin core and I have a problem with the media keys which used by default from system and I cannot disable them. From settings are all disabled and I used dconf-editor to find any bindings there but there isn't. So from where those bindings are enabled?

What changes have you tried so far?

Sometimes a computer's BIOS, provide an option to disable the media keys. I assume this is a notebook computer yes? Well, then that means the media keys are integrated into the hardware, which is why you should check your computer's BIOS, for an option to disable the media keys, or at least to lock them out, to make them not functional.

1 Like

No, it's a desktop pc and I don't want to disable them completely. I just want to disable the default actions the the DE use, so I can use them in kodi as I do in other Desktop Environments. I already wrote what I tried. I didn't make any change in Settings/keyboard shortcuts, because there all actions are disabled. Also I didn't find any setting in dconf-editor about media key shortcuts. So those are enabled by some other way. I don't know if zorin has customize them somehow. I also don't know if gnome do this because I don't like gnome generally and I have some years to use it.

I see your point. I think I cannot much help you on this because I use Zorin OS Lite and I do not use the media keys, at all.

I actually would have then suggested checking settings keyboard shortcuts next, but you mentioned that you already have, and everything was set to disable.

Then my next suggestion involves installing one of these APPS from the Software Store. Decide for yourself, which APP that you need best, or try them all out to see which works the best for you.

The problem is that they reserved from system and those are global shortcuts, so those apps don't help. I don't have problem to set the keyboard shortcuts I want. I already did this. The problem is that the global shortcuts prevent the use of those I've set. For example I have a shortcut in kodi which raise the audio volume uses "Xf86RaiseVolume" media key. But zorin's Desktop Environment(a customized gnome?) uses this key to raise volume globally and display a notification popup.

I found how to disable them.
Using dconf-editor the section is here:
It took me some time to figure out because it's needed to remove the entries there and logout/re-login for applying changes. And it doesn't work to just disable the plugin.


Thank you for returning and providing the info regarding the fix. While I would most certainly consider your situation to be a niche disabling the media keys, you and I both know, there are other's out there who want to do the same thing for the same reasons, so its good to have this info. Cool cool :sunglasses:

If that solved it, can you please mark your post as :ballot_box_with_check:Solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.