How to get latest app


I want to install those apps :

  • solaar
  • Timeshift

but when I install them : sudo apt install
version for solaar is 1.1.1 but real latest one is 1.1.10

Timeshift is 21.09.01 and latest one is 23.12.1

How to get them ? Do i need edit source ,repo or ?

Most usually the software that is available in the repositories is the latest version guaranteed to work with the current system. A lot of the times though you can get out of your way to compile from source and that would still work, but again no guarantees.

I just tried myself with the latest version of Timeshift and while it did install, the UI doesn't launch at all so the only option left is the command line. I tried timeshift --create and it stood there without doing anything for a while. Unfortunately I'm not familiar with the Timeshift, so I don't know if I should provide some additional argument or maybe is just doesn't work.

You can also try with a different version and see if you have better luck with that, instead. But ultimately, if you don't actually need the latest version possible there's no reason to worry about it.

1 Like

Hm.. I am not sure.. Timeshift runs fine, but snapshots are not visible in gui app.

For solaar app, I really need latest version.

But I dont know why on ubuntu 23.10 and even 22.04 Solaar is at least 1.1.9

It's probably due to some missing dependency version or it simply hasn't been tested and included in the repositories yet. In their website they also list an option to install through PyPi for the latest version, so it's worth a try:

1 Like

Yes, but those apps are updated. I know because I switched back to Ubuntu and when I install them via sudo apt install solaar, timeshift last version is there.

Why that is not the case on Zorin as it is also Ubuntu based

this is what i got on Ubuntu :

marko@mb:~$ apt policy solaar
  Installed: 1.1.9+dfsg-1
  Candidate: 1.1.9+dfsg-1
  Version table:
 *** 1.1.9+dfsg-1 500
        500 mantic/universe amd64 Packages
        500 mantic/universe i386 Packages
        100 /var/lib/dpkg/status
marko@mb:~$ apt policy timeshift
  Installed: 23.07.1-1
  Candidate: 23.07.1-1
  Version table:
 *** 23.07.1-1 500
        500 mantic/universe amd64 Packages
        100 /var/lib/dpkg/status

The repository you are referencing is Mantic Minotaur. Did you intentionally add that repository?


No, that is by default. It is Ubuntu 23.10 . But it is the same on Ubuntu LTS ( 22.04.3 LTS)

It appears then, that these are the versions offered as stable in the Mantic repo. If you need a later version due to certain bugfixes or additional features, you can use Flatpaks.

They are not available as Flatpaks unfortunately

Do you:


Both. For example Solaar app ( For my mouse Logitech mx master 3s ) doesnt work correct on that old 1.1.1 version.

Same for Timeshift, backups are not visible in app ( so basically doesnt work)

This is an odd one. Timeshift works properly in previous versions. Have you tried troubleshooting the apps in question?

Sometimes, when having trouble with an app, it being too new can be an issue as much as being too old. I often will roll back to a previous stable version before trying a newer (and potentially buggy since all the new bugs have not yet been worked out) version.

1 Like

This version i tried, it is pretty old. Never had any issues on Ubuntu so didnt bother with versions :smiley:

Likewise, I sometimes aim for not the newest but something a bit ahead of the current offering from the main repos. It's always worth a try at least.

Yes, that is what I did, used app from main Zorin repo

> sudo apt install solaar
> sudo apt install timeshift

I wanted / want latest ones , but it is not possible from Zorin repo

It seems I misunderstood your post.

You are comparing the Mantic Mintotaur repos with Ubuntu 23.10, to Zorin OS (16.3 or 17 Beta?)
You are wanting the latest versions of Solaar and Timeshift on Zorin OS, not Ubuntu 23?

Yeah, I thought that I wrote something wrong :slight_smile:

My first post here is based on Zorin 17 beta. What i wanted , latest available apps for Solaar and Timeshift.

What I posted here post is copy paste from Ubuntu 23.10 Mantic Minotaur repos


No, because I am not so familiar with Zorin repos, and is it ok to add one from Ubuntu or not

The packages you referenced are available on the Interim release distro of Mantic Minotaur, not on the Stable Release Jammy Jellyfish repositories that Zorin OS 17 uses.

I notice that the github of Timeshift also does not show a version 23:

Has this changed maintainer?
You could test the Linux Mint version:

Solaar is available on Github with the release version you are looking for: