How to ignore/disable AMD graphic card

I am trying to install Zorin 16 core on an iMac 2011 i7-2600S with AMD 6770M graphic card.

The graphic card is broken and I have to use the built-in Intel graphic instead.
Booting the installer in safe mode from an USB stick works fine, but booting the installed system from SSD gives a black screen - I assume the graphic card is detected and the system switches to the not working AMD graphic.
How can I 'disable' the graphic card or force the system to always use the built-in Intel graphic?

You can boot in Nomodeset which is "Safe Graphics." This falls back to the Intel card.
On your installation, try tapping esc or tab or left shift key once you see the mother board splash screen. esc is generally for EFI and left shift for MBR.
Proceed to Advanced Options for Zorin and choose Recovery.
Arrow key down to Drop To Prompt
Hit enter
Then

sudo nano /etc/default/grub

Change the line with "quiet splash" to include nomodeset for disabled-at-boot or radeon.modeset=0 to set as -always-disabled so that it looks like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=0"

Ctrl+x to exit, the y key to say yes, then the enter key to close the saved document.
Now run

sudo upddate-grub

Once done, exit out of the Recovery menu and proceed to normal boot.

1 Like

Thank you for the detailed instructions.

At the moment I am struggeling to get into the grub menu. On boot there is only an underline char "_" in the middle of the screen before the screens turns black. No key combination seems to work.

I have tried to edit the SSD's grub file after booting from the USB stick following this instructions [SOLVED]Need to modify /etc/default/grub before 1st boot - Linux Mint Forums but got an error at the end of "upddate-grub" in the chroot environment (something like 'no sdc drive' )

I will try it again later maybe I made a mistake on one mount command. As there is no user data on the SSD I can start over and over again with a clean install if I 'ruin' the grub configuration completly.

But thanks again for "radeon.modeset=0"!

This sounds like a different issue...
This sounds like the Display Manager is failing to load. If you tap ctrl+alt+F3, does it get you to tty terminal?

I have reinstalled Zorin and used the Grub Repair Utility from the USB stick to add 'radeon.modeset=0' to the Grub configuration.

I still see the underscore but after a 15 second wait booting continues and the desktop appears!

Thank you.