How to install Brave Web Browser

I have a feeling I must do this with the terminal. Before I do this is there a native way to do so?

In Ubuntu Mate it and Chrome were readily available in Software store. I’m just curious: is there a reason why neither are readily installable here?

(Yes. I made up a word. Installable.) :stuck_out_tongue:

That is odd that it is not in the Software Store here but is in the Ubuntu mate store.
I think it is likely you will need to use the terminal. Though, personally, I recommend using the terminal for all installs, as much as possible. It allows you to watch what is going on, see any troubles that come up and know what is being installed. The only difference between using the terminal and using the Software Store is that the terminal gives you far greater control.

If doing from terminal, I suggest avoiding the Snap Install.
The Snap Install looks simpler. Must be very appealing to Windows users. But it is plagued with problems and you would be better off with something that updates from source.
Sadly… it requires pasting in Three commands instead of One command.
When will the suffering end?

curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

sudo sh -c ‘echo “deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com lsb_release -sc main” >> /etc/apt/sources.list.d/brave.list’

sudo apt update && install brave-browser brave-keyring

I gave it a try. It didn’t seem to work.

I did reboot because sometimes that’s a thing.

With Linux I don’t know what to do at this point. If I try the commands again (to make sure I got them right) is that bad?

I have just tested that method with the same result.
I just tested trying to get the .deb packages- with no luck. Apt install- same result.
It’s like Ubuntu has wiped ALL varieties except for… Snap Version. The Snap install works.
It’s pretty clear what is going on here… Like MS Windows… They are Forcing their wants on the user. Since most people just go along with it and do not resist or speak up- This kind of behavior is encouraged.

No JohnnyHart… You did nothing wrong. The commands were right- you entered them right. Canonical… Is doing something wrong.

-sigh-

As a member of this board… I am obligated to behave myself. But I believe that as a User of Linux, I am also obligated to speak out against things like this. Canonical is No Better Than Microsoft much of the time.

And we just stumbled right into another instance of Uber-Control.


-shrug- all outdated, now.

OK- I just found a .deb package that may work:
https://github.com/brave/brave-browser/releases/download/v0.66.99/brave-browser_0.66.99_amd64.deb

Hey Aravisian,

Don’t get too upsst. This worked –

What I don’t know is if your first terminal commands were needed or not. That is: did these new ones work by themselves?

1 Like

It seemed to break my ‘Finder/File Explorer’ settings. There was suddenly no way to open a folder with right clicking. :face_with_symbols_over_mouth:

I had to look long and far to remember where the ‘one click to open folders’ setting was.

Those commands look extremely similar. I am guessing that the ones I gave you were slightly outdated.

No prob. I appreciate the assist. Quick question – when a person like myself uses the terminal to install an app – does that app update itself afterwards? Is it stuck at that version? Or do I do some sort of apt update brave kinda thing? lol

And avoid the Software channel as Snap is a security flaw. Use Synaptic Package Manager instead. If ever Snap becomes the only option in future I can see myself turning into a modern day Luddite.

1 Like

I’m still a newbie to Linux so I’m a little confused: when you say avoid the software channel, you mean the software app? The thing we users are supposed to use to get software?

And it was my impression not all software was snap.

And no one’s going to fix this Snap security flaw?

Not unless you set things to update automatically. But you get Notifications of Updates that are available.

Your impression is correct. Not all the software in the store is Snap. Some of it is… And it does not notify you in any way of it.
I have been avoiding the Software Store since I started on Zorin (Linux).
I install primarily from terminal. Sometimes, I use the Synaptic Package Manger which does a much better job of putting control back in our hands.

1 Like

@JohnnyHart Hi, I only got informed of this security issue by email from our city’s Linux User Group co-ordinator - he discovered when updating his Jitsi Meet server that snap.d got installed so he had to reconfigure it - hopefully we’ll be ‘meeting’ later today. I prefer https://meet.jit.si any day over Zoom.

We have gotten off topic… But in the interest of explanation of attitudes…:

The short of it is, as usual… Canonical broke its promise to Never Replace Packages with Snap Packages.

1 Like

Great finds Aravisian - thanks for sharing. :slightly_smiling_face: