How to install network controller driver? Fresh Install

Hi folks,

I'm a complete noob coming from a fresh install, and I have not had the option to connect to wifi via the settings menu. It just says network like this:

After a fair bit of googling, I consulted my lshw output:

wes@wes-Home:~$ sudo lshw -C network
[sudo] password for wes:          
  *-network                 
       description: Network controller
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list
       configuration: driver=iwlwifi latency=0
       resources: irq:18 memory:a2300000-a2303fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 15
       serial: 98:ee:cb:ca:a3:4d
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.13.0-30-generic duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.254.41 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:19 ioport:3000(size=256) memory:a2204000-a2204fff memory:a2200000-a2203fff

and found the appropriate driver from Intel's Linux support site, which I then inserted, confirming that the

iwlwifi-cc-a0-46.ucode

file was out of the tarball and in my

/usr/lib/firmware$ directory.

And lastly I ran

sudo apt full-upgrade

and changed the server in the software and updates menu to the main server (from US), checked for all updates and installed, then restarted (as I have seen recommended here and elsewhere), and I am still having this issue.

I'm able to connect to the internet via ethernet, and bluetooth is working just fine. Can anyone give me some next steps to try?

Thank you in advance for any help! <3

Hm, quite interesting
so the driver is working yet network is still just like "no"?
I'll look into this, seems weird

Edit:

did a search
it seems like a stupid card thingy:

So, without trying to be too "gimme gimme", what can I do about that? Do I need to bust open my desktop, figure out the PCIe slots and swap a couple things around?

Edit: I have a PCIe 1x and 4x slot, both open

basically just open it up, put the network card in the lowest slot possible (basically furthest away from your GPU) and then just, try again, I guess :man_shrugging:

Whelp, here goes nothin'!
Thanks TGRush, will report what happens

Edit: will need to get an M.2 to PCIe 1x adapter, keeping this thread open until that happens.

huh?
do you only have 2 PCIe slots or something?

I do, one 1x and one 4x, and the m.2 on the AX200 uses an A/E key (this one) and I've ordered this to convert it to a PCIe 1x slot.

I've never really been a hardware guy but I feel up to the challenge and I love to learn!

Edit: I'm also going on vacation and this is a desktop, so I'll update in like 2 weeks, cheers 'till then! And thank you for the help @TGRush, I appreciate it!

well for one, you're welcome, glad I could help

but at the same time I am suprised at how you're willing to just do this when there might be something else we're missing (I mean, we don't know, right?)

Okay, had a damn good vacation, took the card out and tried the adapter. No luck, the one I ordered was for laptops and was too big. Ordered and tried another adapter, no luck there either, same deal.

This computer has been a royal pain in my butt for about 6 months now, so I was ready to wipe it one last time and give it to the local IT shop to part out.

But when I turned it back on it worked for some reason? I'm writing this from the wifi, which is connected, and I can't even begin to guess why it's functioning as intended, but it is. Finally.

Thanks again for the help! Also lmao at the profanity filters, I wrote this cussing like three sailors, in equal measure of frustration and joy lmao