How to install Zorin OS on MacBook Pro running Monterey?

Hi,

I recently upgraded my MacBook Pro to macOS Monterey and followed the instructions how to install Linux on macOS, but it did not work. Seems like something has changed.

Please advice on how I can install Linux/ZorinOS on my MacBook Pro running Monterey. Thank you.

Try

Okay. But is there a better way to go about this? I want to be able to dual boot Linux and macOS.

This is the very first time I am trying Linux and I am very new to Linux.

Whilst you wait for someone who has actually done a ZorinOS + MacOS dual-boot to reply, you could have a look at this item I found from a websearch.
For Ubuntu 20.04 substitute ZorinOS 16.

If you already have ZorinOS Live USB prepared, you can skip to chapter 3.

2 Likes

Thank you for this.

The instructions on here are different from what it says on Ubuntu's official website. And apparently in macOS Monterey, you can no longer do it that way.

The in this article you liked, it appears to be a little too complicated for me to try it because the risk of me breaking something is already high enough, and I can't afford to do that. I don't have a spare computer either.

I have, however, flashed a Linux Distro on to a USB drive, and it's ready to install. But the old simple system no longer works the way it has been.

1 Like

I'm having the same issue, and help would be great

Do you use a Mac with Apple Silicon chip (M1)? My MacBook Pro 16 2019 has a T2 chip and I can’t dual boot Linux on it because there are no drivers. Live USB mode will be bootable in few distros but keyboard, trackpad, Wi-Fi, Bluetooth nothing will work and there is no work around available today.

Only option is to run it in a VM and I run a lot of Linux distros on VMWare Fusion for Mac. Or you can refer this Monterey troubleshooting post to find a fix.

1 Like

I used run macOS on Windows PC (Hackintosh) and installed Windows and Linux using Parallels and later Fusion (I switched to Fusion after Parallels adopted a yearly subscription system).

Either VM solutions worked quite well for my use case (mainly for productive apps, no games).

I have an intel mac, and when I try to boot from the USB my screen just goes black and never loads anything, any ideas why?