How to prevent icon theme from being reset when changing from light to dark theme?

Hi! When I switch from the default light to dark theme, the icon theme I set in the Zorin Appearance app is changed back to the default. Is there a way to prevent this from happening?
Thanks!

Welcome to the Zorin Forum! It is wonderful when the newcomer arrives as that is what keeps the forum alive and thriving. As well as improves our knowledge along the way.

Now on to your issue...When does it do this? After you reboot or just randomly ? I assume your using 16 core

Is the OS actually installed or running from LIVE usb?

1 Like

Is it just the Symbolic icons changing color?

If so, then that is set in the themes gtk.css file.
That property is simply color and it is used with the class that you need to change the color of.
As an example, let's say I am using the Zorin icons with the Zorinmenu lite app menu. If I set the property for color as white under the class of zorinmenulite-button, then it will use the Light Color symbolic icon.
e.g.

 #zorinmenulite-button {
    color: white;
}

If I set that to black, it will use the dark color for the symbolic icon.
This applies to the text font color, dragging handles and so on, as well.

In order to address this (which honestly is an unusual request, as having contrasting icons against a background is usualyl what people want), we would need to know in detail which classes and which icons are affected.

Or...
If I completely misunderstood the O.P.

Hi! Thanks for the welcome :slight_smile:

The OS is installed (dual-booting with Win 11, but I doubt dual-boot has anything to do with it) and the icon theme is reset any time that the light theme (blue variant) is switched to the dark one (blue variant too) using Zorin Appearance or the built-in "theme schedule". And yes, using 16 core.

Hi! I might not have been clear. The problem is not with the GTK theme, I'm using the default ones, the problem is with a custom icon theme, which keeps resetting to the default icons. I installed Papirus and it correctly showed in the drop-down. It was successfully applied too, but when the theme changes from light to dark, the icons changed.

I explained, even with an example, how the gtk theme can determine icon color.

1 Like

I know. Symbolic icons are not a problem, nor is their color a problem. It's the full icon theme, including the ones in the dock/panel/app list/mime-types/etc. See image for clarity:

My question is if there's any way to make GTK theme changes not affect icon theme choice. Hopefully, this clarifies the issue.

1 Like

Ah, I am sorry for the misunderstanding that I had there.

And this may play a part into what led to my misunderstanding: Changing the gtk theme should not change the icon theme. It may be the unexpected nature of the problem.

No worries! It is unexpected behavior, I had never seen it before on Linux. Let me know if you have any ideas, otherwise, I'll wait and see if anyone else does! ^^

2 Likes

I just logged into Gnome (I do not use Gnome, I use Zorin OS Lite XFCE) and tried repeatedly changing out the theme.
The icon set remained set.
You might try

sudo apt install --reinstall zorin-appearance

just to see if it is the application itself.
You may also try using gnome-tweak tool

sudo apt install gnome-tweaks

then launch from the App menu with Tweaks and disable All Gnome Extensions (temporarily) and test changing the theme out to see if the Icon Theme stays constant. If it does, it becomes a matter of narrowing down which extension is interfering with the theme application.
Other than that, hopefully some regular Gnome Users may speak up.

1 Like

Both reinstalling zorin-appearance and disabling all extensions didn't change anything. For some reason, when changing the GTK theme using gnome-tweaks, the icon theme reset is delayed (it stays with Papirus for a while before resetting to the default).

Thanks for the help anyway —fortunately for us the Zorin icons are already pretty by default!

2 Likes

I'm baffled at this as I tried by change my theme and it works fine after reboot... Never one to give up I'll dig after the evening meal..I hear the wife paging me as I write.

1 Like