How to prevent Zorin from changing Firefox startpage on every restart

Every time I restart my computer and start Firefox my Startpage keeps resetting to start.zorin.os
Current behavior:
Currently
Expected behavior:

I don't suffer from this problem.

Which version of FF are you using?

Zorin isn't doing this, the FF software you are using is.

1 Like

You're using the Ubuntu version.... That's one of your problems.

I highly suggest you uninstall that, go over to Firefox and download the tar from them directly.

Then follow the simple instructions to install it. Page down, not the Flatpak, not the snap, you want the Mozilla Build instructions

In simplistic terms, download the tar, right click extract it, copy it over to your opt/ file as root then run the symlink in terminal as shown on the instructions... Done. It's in essence 3 steps out of the 6 you need to do.

2 Likes

Updating to Snap with version 107 resolved the issue.

There was no need for that. The start page of zorin Os can be changed to any site you want by going into settings. Save yourself some hassle and install via Synaptic, not Store, not flatpak, not snapd.

2 Likes

+1 as i do the same with firefox. + firefox gets updated when they release a update. When i use the stock version i need to wait a few days before it gets updated. Running firefox 107.0 as we speak.

3 Likes

Yup, I don't have to wait for an update for fix anything. Plus I don't have a 1/4 of the problems all these people do using the Flatpak, Snap or Ubuntu versions

3 Likes