How to purge stubborn non-package files?

I tried installing leagueoflegends-git GitHub - kyechou/leagueoflegends: League of Legends install and launch wrapper for Linux through the guide here How to Install League of Legends on Linux - LinuxForDevices until I realized it's for VM (or the github says so?). I purged wine-lol and tried purging leagueoflegends (I tend to use *), but while wine-lol did get purged, leagueoflegends files didn't. I remove all leagueoflegends files I could manually, but some show up, but there is no delete option. Furthermore, it decided to add league of legends to my menu, which means something got installed(?).

Synaptic shows nothing.

I did all steps from the guide until '' leagueoflegends install'' since it was the only one not working, it was saying it cannot find the package.

I tried sudo apt-get update && sudo apt-get autoremove && sudo apt-get autoclean but it didn't help.

Those are the files I see if I try to search for leagueoflegends:

You can safely remove those files manually. The .deb file in this case is a transition for downloading and install further files.

1 Like

It doesn't let me. There is no remove option and Delete on keyboard doesn't work.

Even using the sudo command?

It may not be the right answer but I'd go with sudo nautilus then delete files.

2 Likes

I agree with the above.

When installing from source, like git, then using make, the developer is responsible to include the command to remove.

sudo make remove

Should they not include that, then the only recourse is to elevate to root and search out and remove the files yourself. It is annoying.

1 Like

Sudo nautilus worked. Thank you.